Ask Your Question
0

network interfaces configure for Hokuyo ust 10lx

asked 2017-04-19 23:13:36 -0600

dehou14 gravatar image

Hi all, I have a Hokuyo ust 10LX LRF, which use ethernet RJ45 connector, rather than USB.

Sequence listed below:

Step 1. Use 10LX's default setting , 192.168.0.10 as LiDAR IP address.

Step 2. Set network.

$ sudo vi /etc/network/interfaces

auto lo

iface lo inet loopback

auto eth0

allow-hotplug eth0

iface eth0 inet static

address 192.168.0.15

netmask 255.255.255.0

Step 3. Power on LiDAR with 12V@1000mA power supply,

Step 4. Plug RJ45 connector into PC's ethernet port.

Step 5. However get errors saying 'Destination Host Unreachable'.

$ ping 192.168.0.15

64 bytes from 192.168.0.15: icmp_seq=1 ttl=64 time=0.032 ms

64 bytes from 192.168.0.15: icmp_seq=2 ttl=64 time=0.037 ms ...

ping PC okay, but fail to LiDAR:

$ ping 192.168.0.10

PING 192.168.0.10 (192.168.0.10) 56(84) bytes of data.

From 192.168.0.15 icmp_seq=1 Destination Host Unreachable

From 192.168.0.15 icmp_seq=2 Destination Host Unreachable

From 192.168.0.15 icmp_seq=3 Destination Host Unreachable ...

Thanks very much for your help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-04-20 21:40:33 -0600

Geoff gravatar image

Check the output of ip route and make sure that there is a route going to the 192.168.0.0/24 block using eth0.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-04-19 23:09:05 -0600

Seen: 782 times

Last updated: Apr 20 '17