Ask Your Question
0

Neither rospack find nor roscd can find ca_driver

asked 2017-04-17 21:40:40 -0500

Awais gravatar image

Neither rospack find nor roscd can find ca_driver, I have tried installing on two different computer using exact instruction given on git page and also tried adding the ROS Path, passing full path to roslaunch but it says:

" [create_2.launch] is neither a launch file in package [ca_driver] nor is [ca_driver] a launch file name The traceback for the exception was written to the log file"

Please help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-04-17 22:15:21 -0500

ahendrix gravatar image

It looks like the instructions tell you to clone the repository in ~/create_ws, but you actually need to clone it into ~/create_ws/src and then cd back to ~/create_ws to run rosdep update and the remaining build steps.

edit flag offensive delete link more

Comments

Submitted a pull request to clarify their documentation: https://github.com/AutonomyLab/create...

ahendrix gravatar image ahendrix  ( 2017-04-17 22:21:47 -0500 )edit

Thanks. It is now installed properly

Awais gravatar image Awais  ( 2017-04-17 23:20:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-17 21:40:40 -0500

Seen: 65 times

Last updated: Apr 17 '17