Ask Your Question
0

Has anyone attempted to install vicon_bridge on an ubuntu mate running on a raspberry pi? Seems to have a compatibility issue when making.

asked 2017-04-10 12:21:30 -0600

yc0123 gravatar image

Error reads /usr/bin/ld: skipping incompatible /home/atrv/catkin_ws/src/vicon_bridge/vicon_sdk/Vicon_SDK_1.3_Linux/32-bit/libViconDataStreamSDK_CPP.so when searching for -lViconDataStreamSDK_CPP

Seems to be only an issue with raspberry pi, or ARM boards in general? I have successfully used vicon_bridge with my laptop and pc.

Hope someone have some suggestions? Or perhaps I should look for a substitution for the R-pi?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-04-10 15:03:05 -0600

ahendrix gravatar image

It looks like the pre-compiled Vicon library that is part of that package is compiled for Intel processors, and won't work on ARM.

I don't know anything about Vicon, but it would be worth checking their website to see if the provide a version of their SDK that is compiled for ARM.

You may also want to check the github issues for the vicon_bridge package to see if anyone else has reported this before.

edit flag offensive delete link more

Comments

Ahh thanks! Seems like that is indeed the case and seems like I am out of luck for now. https://github.com/ethz-asl/vicon_bri...

yc0123 gravatar imageyc0123 ( 2017-04-11 11:43:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-10 12:21:30 -0600

Seen: 189 times

Last updated: Apr 10 '17