Ask Your Question
0

about xmlrpcpp/XmlRpcException.h

asked 2017-04-09 21:46:45 -0500

lowme gravatar image

updated 2017-04-10 04:28:02 -0500

mgruhler gravatar image

when I catkin_make the robot_localization package it says:

fatal error: xmlrpcpp/XmlRpcException.h: No such file or directory
 #include <xmlrpcpp/XmlRpcException.h>

how to solve it?

edit retag flag offensive close merge delete

Comments

Are you trying to compile the robot_localization package from source code? If so, have you tried to run rosdep before catkin_make?

DavidN gravatar image DavidN  ( 2017-04-10 02:27:41 -0500 )edit

I have done as you said,but it don't work

lowme gravatar image lowme  ( 2017-04-10 06:48:13 -0500 )edit

I replaced #include <xmlrpcpp xmlrpcexception.h=""> as #include <xmlrpcexception.h> and #include <string.h> it works thank you.

lowme gravatar image lowme  ( 2017-04-10 07:27:31 -0500 )edit

Which branch are you using?

Tom Moore gravatar image Tom Moore  ( 2017-04-11 04:24:08 -0500 )edit

I want to fuse GPS IMU and DMI.

lowme gravatar image lowme  ( 2017-04-11 07:33:11 -0500 )edit

What branch of the GitHub repository are you using?

Tom Moore gravatar image Tom Moore  ( 2017-04-11 07:49:11 -0500 )edit

I'm having the same issue. Just cloned the latest version of kinetic-devel. There is no directory named xmlrcpp in the include/robot_localization directory, is it meant to be installed by the user?

zobocop gravatar image zobocop  ( 2017-04-13 05:05:26 -0500 )edit

Fixed by running rosdep install [package] on any packages that threw an error during catkin_make. For robot_localization this triggered an apt-get installation. I had originally used git clone as I was updating an old version of robot_localization.

zobocop gravatar image zobocop  ( 2017-04-13 05:50:24 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-04-10 07:27:25 -0500

lowme gravatar image

I replaced #include <xmlrpcpp xmlrpcexception.h=""> as #include <xmlrpcexception.h> and #include <string.h> it works thank you.

edit flag offensive delete link more
0

answered 2017-04-10 04:42:05 -0500

updated 2017-04-10 04:44:27 -0500

I think you might have not installed the xmlrpcpp package.

sudo apt install ros-$ROS_DISTRO-xmlrpcpp

edit flag offensive delete link more

Comments

I have installed the package bu it didn't work

lowme gravatar image lowme  ( 2017-04-10 06:42:13 -0500 )edit

If you have installed the package and it is still not recognised, you might have configured ROS incorrectly. Check your ~/.bashrc for the following lines: source /opt/ros/$ROS_DISTRO/setup.bash and

source ~/catkin_ws/devel/setup.bash The first line MUST be in your bashrc.

gstavrinos gravatar image gstavrinos  ( 2017-04-10 07:06:42 -0500 )edit

Good job!!

gstavrinos gravatar image gstavrinos  ( 2017-04-10 07:44:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-04-09 21:46:45 -0500

Seen: 935 times

Last updated: Apr 10 '17