ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Unable to install ROS on Ubuntu 14.04.5

asked 2017-03-31 02:00:13 -0500

jaskaranvirdi gravatar image

Hi, After following all the steps on ROS Wiki,

I get stuck on

 sudo apt-get install ros-indigo-desktop-full

I get the error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-indigo-desktop-full : Depends: ros-indigo-desktop but it is not going to be installed
                           Depends: ros-indigo-perception but it is not going to be installed
                           Depends: ros-indigo-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have tried to fix dependencies

sudo apt-get -f install

I have also tried

sudo apt-get install libsdformat1

Nothing has worked.

Ouput of:

uname -m

I didn't try

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic

Because it can break X-Server.

What to do?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-04-03 16:37:50 -0500

jaskaranvirdi gravatar image

I installed libboost1.54-dev

sudo apt-get install libboost1.54-dev

And after that did the full install. It worked.

edit flag offensive delete link more


DIdn't work

mcamarneiro gravatar image mcamarneiro  ( 2017-09-26 09:40:19 -0500 )edit

answered 2017-03-31 09:44:19 -0500

emef gravatar image

Did you try sudo apt-get install libgl1-mesa-dev-lts-utopic? If all else fails, you can build from source

edit flag offensive delete link more

Question Tools


Asked: 2017-03-31 02:00:13 -0500

Seen: 644 times

Last updated: Apr 03 '17