Ask Your Question
0

robot_localization ukf not publishing map->odom

asked 2017-03-29 10:39:24 -0600

agbj gravatar image

updated 2017-04-12 04:51:12 -0600

I am trying to use the ukf node in the robot_localization but this node is not publishing the transform from the frame map to odom and the following error message appear: Could not obtain transform from odom to map. Error was "map" passed to lookupTransform argument target_frame does not exist. My config file is the following:

frequency: 30

sensor_timeout: 0.1

two_d_mode: true

transform_time_offset: 0.0

transform_timeout: 0.0

print_diagnostics: true

debug: false

debug_out_file: ~/.ros/robot/rDebug.log


map_frame: map             
odom_frame: odom            
base_link_frame: base_link  
world_frame: map           


odom0: odom


odom0_config: [true,  true,  false,
               false, false, true,
               false, false, false,
               false, false, false,
               false, false, false]


odom0_queue_size: 2


odom0_nodelay: false


odom0_differential: false


odom0_relative: false


odom0_pose_rejection_threshold: 5
odom0_twist_rejection_threshold: 1


pose0: pose
pose0_config: [true,  true,  false,
               false, false, true,
               false, false, false,
               false, false, false,
               false, false, false]
pose0_differential: true
pose0_relative: false
pose0_queue_size: 5
pose0_rejection_threshold: 2  
pose0_nodelay: false


use_control: true

stamped_control: false

control_timeout: 0.2

control_config: [true, false, false, false, false, true]

acceleration_limits: [1.3, 0.0, 0.0, 0.0, 0.0, 3.4]

deceleration_limits: [1.3, 0.0, 0.0, 0.0, 0.0, 4.5]

acceleration_gains: [0.8, 0.0, 0.0, 0.0, 0.0, 0.9]

deceleration_gains: [1.0, 0.0, 0.0, 0.0, 0.0, 1.0]


process_noise_covariance: [0.05, 0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0.05, 0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0.06, 0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0.03, 0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0.03, 0,    0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0.06, 0,     0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0.025, 0,     0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0.025, 0,    0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0.04, 0,    0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0.01, 0,    0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0.01, 0,    0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0.02, 0,    0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0.01, 0,    0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0.01, 0,
                           0,    0,    0,    0,    0,    0,    0,     0,     0,    0,    0,    0,    0,    0,    0.015]


initial_estimate_covariance: [1e-9, 0,    0,    0,    0,    0,    0,    0,    0,    0,     0,     0,     0,    0,    0,
                              0,    1e-9, 0,    0,    0,    0,    0,    0,    0,    0,     0,     0,     0,    0,    0,
                              0,    0,    1e-9, 0,    0,    0,    0,    0,    0,    0,     0,     0,     0,    0,    0,
                              0,    0,    0 ...
(more)
edit retag flag offensive close merge delete

Comments

Can you please change the formatting of your config file to use the code formatting (tiny box with ones and zeros)? Also, please post a sample message from every input. What are you using to generate the odom->base_link transform?

Tom Moore gravatar imageTom Moore ( 2017-04-11 04:27:35 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-04-07 10:10:47 -0600

Orhan gravatar image

Your question is already answered here:

Using robot_localization with amcl

edit flag offensive delete link more

Comments

Thank you for the answer but to publish both the pose and odometry in the same frame to get the transform from map to odom. I think i have to publish the odometric information in the map frame. Correct me if I am wrong. But the node that publishes the odometry does not know how to transform the pose

agbj gravatar imageagbj ( 2017-04-10 04:00:08 -0600 )edit

That thing explained in the link above. If you tune correctly (remappings etc.) It publishes transforms between frames automatically.

Orhan gravatar imageOrhan ( 2017-04-10 04:11:40 -0600 )edit

The frame between map and odom is being published by the ukf node, but it is incorrect because in rviz the robot just stands still and i think it is because I am publish both the pose and odometry in the odom frame. When I use only my localization node the robot is able to localize itself reasonably

agbj gravatar imageagbj ( 2017-04-10 04:20:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-29 10:39:24 -0600

Seen: 466 times

Last updated: Apr 12 '17