Ask Your Question
0

Code::Blocks and ROS Setup - rospack export returns empty line

asked 2017-03-26 11:36:03 -0600

brharper13 gravatar image

Hi all,

I'm trying to integrate Code::Blocks with the actionlib_tutorials package to no avail. I'm using the ROS IDEs Wiki page for Code::Blocks and I'm getting a blank line when using:

rospack export --lang=cpp --attrib=cflags PackageName

rospack export --lang=cpp --attrib=lflags PackageName

I've created the package using catkin tools and have successfully run catkin build in the package root.

My ROS_PACKAGE_PATH is:

/TigerBotWS/TigerBot/src/actionlib_tutorials:/opt/ros/kinetic/share

And using tree on my package looks like the following:

. ├── build

│   ├── actionlib_tutorials

│   └── catkin_tools_prebuild

├── devel

│   ├── etc

│   ├── lib

│   └── share

├── logs

└── src

│   └── actionlib_tutorials

Any idea as to why the cflags attribute from rospack export might be blank?

Thanks in advance.

(P.S. There was a previous topic about this here. The tutorial is points to did not solve my issue hence the re-post)

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-03-27 03:34:04 -0600

angeltop gravatar image

I haven't used Code::Blocks before, so I am not sure if this creates your problem, but I am sure that your ROS_PACKAGE_PATH is not initialized correctly.

ROS_PACKAGE_PATH should point to the src folder of your workspace. For correct initialization of this environment variable do:

source /opt/ros/kinetic/setup.bash 
cd /TigerBotWS/TigerBot
catkin build
source devel/setup.bash

In addition, you could export these flags with the export tag of actionlib_tutorials/package.xml

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-26 11:33:04 -0600

Seen: 222 times

Last updated: Mar 27 '17