Ask Your Question
1

Problem with rqt, siplib.c - KDE Neon

asked 2017-03-11 08:29:07 -0600

Aiven gravatar image

Hi,

I'm use KDE Neon as main system and have the problem with rqt. Launching any rqt program I have thу same answer.

$ rqt

python: siplib.c:12299: sipEnumType_alloc: Assertion `sipTypeIsEnum(currentType)' failed.

Aborted

Maybe anyone know how to fix it, or can give me advice about debug this problem ?

Thanks.

p.s. Yes, I now that KDE Neon is not recommended system for ROS. But changing the system because one program did'n work - is not a linux-way.

edit retag flag offensive close merge delete

Comments

Have you solved this? I'm switching to neon from kubuntu just now because of desktop issues.

Orhan gravatar imageOrhan ( 2017-03-27 08:35:19 -0600 )edit

Some colleagues and me struggle with the same issue... Hope it is fixed soon!

Pascal Becker gravatar imagePascal Becker ( 2017-03-27 11:19:34 -0600 )edit

I think there are more issues coming for us. Because no one tested ROS with newest Qt. If your usually used applications are kde based too, I suggest kubuntu. Because they aren't well configurable on unity.

Orhan gravatar imageOrhan ( 2017-03-27 13:50:11 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-03-27 08:52:44 -0600

Aiven gravatar image

updated 2017-05-28 11:50:49 -0600

Problem solved with last distr update (26.03.2017) - NO

edit 28.05.2017 I solve this problem with compile rtq by hand.

cd catkin_ws/src/
git clone https://github.com/ros-visualization/qt_gui_core.git
git clone https://github.com/ros-visualization/rqt.git
git clone https://github.com/ros-visualization/rqt_common_plugins.git
git clone https://github.com/ros-visualization/rqt_robot_plugins.git
cd ..
catkin_make install

I have some problems with compiling of rqt_gui. But all works.

edit flag offensive delete link more

Comments

Just updated today, but the issue is still the same :-/

Pascal Becker gravatar imagePascal Becker ( 2017-04-04 02:05:33 -0600 )edit

Confim. It's broke again =(

Aiven gravatar imageAiven ( 2017-05-20 15:25:25 -0600 )edit

Have you reported any of this on the appropriate issue trackers?

gvdhoorn gravatar imagegvdhoorn ( 2017-05-28 12:14:16 -0600 )edit
0

answered 2017-05-29 07:38:28 -0600

Pascal Becker gravatar image

Jep, it is already tracked here: https://github.com/ros-visualization/...

I compiled rqt also myself and get the same errors with rqt_gui. During runtime it says

RuntimeError: the sip module implements API v11.0 to v11.3 but the module requires API v12.1

with installed sip version 4.19.3.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-03-11 08:29:07 -0600

Seen: 447 times

Last updated: May 29 '17