Ask Your Question
0

ERROR: cannot launch node of type [rplidar_ros/rplidarNode]: can't locate node [rplidarNode] in package [rplidar_ros]

asked 2017-03-08 09:19:47 -0600

Shilpan gravatar image

updated 2017-03-08 13:38:16 -0600

I keep on receiving this error every time i execute roslaunch rplidar_ros view_rplidar.launch

I have executed source devel/setup.bash as well.

In addition, rplidar_ros exists on my rospack list.

When i execute, Rviz map/grid shows up, but with no laser scans.

please help with this matter.

I am not sure what is causing the error.

edit retag flag offensive close merge delete

Comments

1

Check your spelling for rplidar. you have an additional letter i in there.

Rayner gravatar imageRayner ( 2017-03-08 11:26:30 -0600 )edit

still doesn't work. any clues?

Shilpan gravatar imageShilpan ( 2017-03-08 13:40:17 -0600 )edit

what do you think might be causing it?

Shilpan gravatar imageShilpan ( 2017-03-08 13:41:38 -0600 )edit

Please give some more information: How is your workspace set up, did you install rplidar from debs or from source, is it in your workspace?

My guess currently is, you installed from source and haven't compiled it.

mgruhler gravatar imagemgruhler ( 2017-03-09 01:30:29 -0600 )edit

Okay so it works now. I installed from source, so i needed to install rplidarNode on src.

source /opt/ros/kinetic/setup.bash roslaunch rplidar_ros view_rplidar.launch

Shilpan gravatar imageShilpan ( 2017-03-09 09:39:09 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-03-14 01:32:53 -0600

Shilpan gravatar image

just do the follwoing commands:

source /opt/ros/kinetic/setup.bash

otherwise remove the files and git clone again and run catkin_make . Works every time.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-03-08 09:19:47 -0600

Seen: 1,886 times

Last updated: Mar 14 '17