Errors while running a virtual husky

asked 2017-03-02 16:18:51 -0600

SarSam gravatar image

I am following this tutorial: https://www.clearpathrobotics.com/ass...
Running this:

$roslaunch husky_gazebo husky_empty_world.launch

gives me the following error message:

... logging to /home/viki/.ros/log/e4fa538c-ff94-11e6-a4c2-080027b46cdd/roslaunch-c3po-3773.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/indigo/share/xacro/xacro.py", line 60, in <module>
    xacro.main()
  File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 662, in main
    eval_self_contained(doc)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 597, in eval_self_contained
    eval_all(doc.documentElement, macros, symbols)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 533, in eval_all
    eval_all(body, macros, scoped)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 573, in eval_all
    eval_all(cloned, macros, symbols)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 533, in eval_all
    eval_all(body, macros, scoped)
  File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 512, in eval_all
    (str(name), str(node.tagName)))
xacro.XacroException: Invalid parameter "topic" while expanding macro "sick_lms1xx"
while processing /opt/ros/indigo/share/husky_gazebo/launch/spawn_husky.launch:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/indigo/share/xacro/xacro.py '/opt/ros/indigo/share/husky_gazebo/urdf/description.gazebo.xacro'     laser_enabled:=true     ur5_enabled:=false     kinect_enabled:=false     ] returned with code [1]. 

Param xml is <param command="$(find xacro)/xacro.py '$(arg husky_gazebo_description)'     laser_enabled:=$(arg laser_enabled)    ur5_enabled:=$(arg ur5_enabled)     kinect_enabled:=$(arg kinect_enabled)  " name="robot_description"/>
The traceback for the exception was written to the log file

and when I did this:

roslaunch husky_viz view_robot.launch

I get this:

... logging to /home/viki/.ros/log/4615235e-ff95-11e6-8bef-080027b46cdd/roslaunch-c3po-7396.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://c3po:34708/

SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.8

NODES
  /
    rviz (rviz/rviz)

auto-starting new master
process[master]: started with pid [7408]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 4615235e-ff95-11e6-8bef-080027b46cdd
process[rosout-1]: started with pid [7421]
started core service [/rosout]
process[rviz-2]: started with pid [7438]
[ INFO] [1488492728.382519122]: rviz version 1.11.3
[ INFO] [1488492728.382848996]: compiled against OGRE version 1.8.1 (Byatis)
libGL error: pci id for fd 24: 80ee:beef, driver (null)
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found ...
(more)
edit retag flag offensive close merge delete

Comments

in Virtual Box

yeah .. and that is really not well supported (not necessarily by ROS, but by anything). You can try to see if you can somehow find some decent graphics drivers for the VBox hw, but I've not heard many success stories about VBox and RViz / Gazebo.

gvdhoorn gravatar imagegvdhoorn ( 2017-03-03 02:11:36 -0600 )edit

Are you running from source or debs?

tonybaltovski gravatar imagetonybaltovski ( 2017-03-04 11:28:31 -0600 )edit

@tonybaltovski , I didn't understand your question! I am running it from Terminal in Ubuntu which I installed on Virtual Box

SarSam gravatar imageSarSam ( 2017-03-05 16:35:43 -0600 )edit