Ask Your Question
1

OctoMap installation

asked 2017-03-02 04:30:15 -0600

HenrySleek gravatar image

Hello,

I am quite new to ROS and Ubuntu, so this may be a silly question, but I could not solve it. I am running Ubuntu 14.04 and ROS Indigo, and I would like to install all the OctoMap packages in a separate workspace, in order to source it when I want to use it. I cloned all the folders from GitHub ( https://github.com/OctoMap ), but when I try to build the workspace with catkin_make, I have an error saying that the octomap main package ( https://github.com/OctoMap/octomap ) contains 'non-catkin packages in it, and catkin cannot build a non-homogeneous workspace without isolation'. How can I solve this problem? Should I download a different version of that package?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-03-02 06:46:38 -0600

Sebastian Kasperski gravatar image

The OctoMap library is not a catkin package, so you have to cmake/make install it manually and then build the ros-related packages using catkin_make. I think there is also a binary package liboctomap-dev which you could just install instead (but which might be outdated though).

edit flag offensive delete link more

Comments

Uhm, I see. So I should copy it in the workspace/src and then install it manually, and then catkin_make at the root of the workspace? Sorry but I am not sure about all these processes, they are new to me.

HenrySleek gravatar image HenrySleek  ( 2017-03-02 07:57:27 -0600 )edit

The point is that I already have some OctoMap packages under opt/ros/indigo/share (that I installed along with other things I previously installed, the robot and MoveIt!, I guess), so I don't want to overwrite them. That's why I want to do this in a separate workspace, for experimenting with it.

HenrySleek gravatar image HenrySleek  ( 2017-03-02 07:59:37 -0600 )edit

Don't put it in your workspace at all (the octomap-lib, because it is not a catkin package). Only catkin-packages should go into your workspace. It will then be installed to /usr/local. However catkin package will likely use your octomap from the ros-binaries, so you might have to unistall these.

Sebastian Kasperski gravatar image Sebastian Kasperski  ( 2017-03-02 11:16:25 -0600 )edit

Btw. I agree with mig's comment, why don't you use the deb-installed octomap that comes with ros (and is already installed on your system?)

Sebastian Kasperski gravatar image Sebastian Kasperski  ( 2017-03-02 11:17:37 -0600 )edit

Ok, I finally installed it from debs (sudo apt-get install ros-indigo-octomap ros-indigo-octovis). Thank you. But there is nothing that is contained here ( https://github.com/OctoMap/octomap ), no .cpp, no files, no nothing. Just an empty shell. How do I use it now? For opening octovis, for example.

HenrySleek gravatar image HenrySleek  ( 2017-03-03 03:45:49 -0600 )edit

I asked a different question for being more specific on my problem: http://answers.ros.org/question/25606... If you know the answer, please answer there. It would be extremely helpful.

HenrySleek gravatar image HenrySleek  ( 2017-03-03 04:48:32 -0600 )edit
1

answered 2017-03-02 06:45:29 -0600

mgruhler gravatar image

Why would you want to do that and not install the debians? It does not matter if they are sourced, as long as you don't start any of the octomap stuff...

To answer your question: you need to do a catkin_make_isolated. There are several questions about this on ROS answers which googleing reveals...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-03-02 04:30:15 -0600

Seen: 2,064 times

Last updated: Mar 02 '17