ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

dynamicEDTOctomap.h: No such file or directory

asked 2017-02-28 11:46:06 -0500

swethmandava gravatar image

I installed dynamicedt3d library using sudo apt-get install ros-indigo-dynamicedt3d Included in my CMakeLists as:

set(DYNAMICEDT3D_LIBRARIES "/opt/ros/indigo/lib/") include_directories( ${DYNAMICEDT3D_LIBRARIES} ) add_executable(get_occupancy src/get_occupancy.cpp) target_link_libraries(get_occupancy $(DYNAMICEDT3D_LIBRARIES))

But while doing a catkin_make, I still get the error fatal error: dynamicEDTOctomap.h: No such file or directory #include <dynamicedtoctomap.h>

Can somebody help me figure this out?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-03-02 06:35:24 -0500

mgruhler gravatar image

updated 2017-03-02 06:36:10 -0500

What you did was to declare your library file to be the include directory. This is clear whythis fails...

To quote from the dynamicEDT3DConfig.cmake:

#  Usage from an external project:
#    In your CMakeLists.txt, add these lines:
#    FIND_PACKAGE(dynamicedt3d REQUIRED )

You should probably also add dynamic-edt-3d as a depend to your package.xml.

edit flag offensive delete link more


I was following a tutorial given here But I think that is for an older version and the issue is solved now that I went back to simply finding package and including directories. Thanks!

swethmandava gravatar image swethmandava  ( 2017-07-25 16:12:06 -0500 )edit

Question Tools


Asked: 2017-02-28 11:46:06 -0500

Seen: 474 times

Last updated: Mar 02 '17