Ask Your Question
0

ROS on Ubuntu/Lubuntu 16.10

asked 2017-02-27 16:09:57 -0500

AL gravatar image

Hello,

I have been trying for a while to install ros on lubuntu 16.10 and it's not working. On the official site the most recent Ubuntu version they refer to is: 14.04, does this mean that the ubuntu 16.10 is still not supported or am I not doing it right?

Thanks in advance

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-02-27 20:45:53 -0500

tfoote gravatar image

ROS REP 3 for supported platforms. 16.10 support will come with the upcoming Lunar release.

edit flag offensive delete link more
1

answered 2017-02-27 20:16:16 -0500

The three latest ROS distributions nowadays (28.02.2017) are Indigo, Jade and Kinetic.

  • According to this, ROS Indigo precompiled binaries are available only on Saucy (13.10) and Trusty (14.04).

  • According to this, ROS Jade precompiled binaries are available only on Trusty (14.04), Utopic (14.10) and Vivid (15.04).

  • According to this, ROS Kinetic precompiled binaries are available only on Wily (Ubuntu 15.10), Xenial (Ubuntu 16.04) and Jessie (Debian 8).

So, no 16.10 is on the list (sorry). However you could try to compile from source (indigo instructions here, kinetic instructions here. This however I wouldn't recommend unless you have some expertise using ROS.

The easiest thing to do would be to format your PC with 14.04 for indigo or 16.04 for kinetic, both are LTS versions being ROS Kinetic the recommended one by ROS (see this).

I hope this helps,

Oscar

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-27 16:09:57 -0500

Seen: 1,947 times

Last updated: Feb 27 '17