Ask Your Question
0

Unable to receive messages on ROS network

asked 2017-02-11 10:31:28 -0500

kartikmadhira1 gravatar image

I am currently running a master node on my Jetson TK1(IP - 10.42.0.15) and a remote PC running ubuntu(IP - 10.42.0.1). I have gone through all the setup shown in the setup and multiple machines. Also, I am able to ping into both of them and netcat results are perfect too. I have also gone through ROS answers on setting up the /etc/hosts file. But, when I try to do the rostopic list after a roscore on tegra ,I just dont see anything.

my setup on tegra is:

export ROS_IP=10.42.0.15
export ROS_HOSTNAME=10.42.0.15
export ROS_MASTER_URI=http://10.42.0.15:11311/

Variables setup on PC are:

export ROS_IP=10.42.0.1
export ROS_HOSTNAME=10.42.0.1
export ROS_MASTER_URI=http://10.42.0.15:11311/
edit retag flag offensive close merge delete

Comments

When you run roscore on the master, what is printed to the command line?

epsilonjon gravatar imageepsilonjon ( 2017-02-11 11:09:41 -0500 )edit

This could be roscore binding its socket to the wrong IP, good question @epsilonjon.

Also: @kartikmadhira1: using ROS_IP and ROS_HOSTNAME at the same time is not recommended / necessary. I'd stick to ROS_IP if you are in fact not resolving hostnames.

gvdhoorn gravatar imagegvdhoorn ( 2017-02-11 11:19:30 -0500 )edit

@epsilonjon , The ros master is started with the given IP name and I'm able to run rplidar node too.

kartikmadhira1 gravatar imagekartikmadhira1 ( 2017-02-11 11:49:12 -0500 )edit

@gvdhoorn tried with only ROS_IP, but without any help. messages aren't coming.

kartikmadhira1 gravatar imagekartikmadhira1 ( 2017-02-11 11:55:19 -0500 )edit

@kartikmadhira1 Are you running rplidar and rostopic list on the master or on the other machine?

epsilonjon gravatar imageepsilonjon ( 2017-02-11 12:21:06 -0500 )edit

@epsilonjonrplidar on the master and rostopic list on PC.

kartikmadhira1 gravatar imagekartikmadhira1 ( 2017-02-11 12:22:48 -0500 )edit

@gvdhoorn tried with only ROS_IP, but without any help. messages aren't coming.

my comment wasn't meant as a "this will solve your problem" kind of comment, but more as a general remark. The semantics of the two variables are different. They shouldn't be used at the same time.

gvdhoorn gravatar imagegvdhoorn ( 2017-02-12 07:00:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-02-11 13:34:28 -0500

kartikmadhira1 gravatar image

Finally figured it, firewall was at place in the master so did sudo ufw disable to allow port connections and it worked.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-11 10:31:28 -0500

Seen: 189 times

Last updated: Feb 11 '17