Ask Your Question
0

Empty Octomap in RGBDSLAM

asked 2017-02-02 10:23:33 -0600

danmou gravatar image

updated 2017-02-06 04:09:17 -0600

I am using rgbdslam_v2 with the Intel Realsense R200 on ROS Kinetic. It seems to be working fine and I am getting a point cloud in the RGBDSLAM GUI. However, when I turn off the cloud display to view the Octomap, it seems to be empty. Saving the Octomap also just saves an empty Octomap. I have tried enabling online octomapping and running the Point Cloud Occupancy Filter menu item (which I am not quite sure how is supposed to be used - is it for generating the Octomap when online octomapping is disabled?), but to no avail.

Is there something I have missed?

Thanks.

edit retag flag offensive close merge delete

Comments

The voxel filter is meant to geometrically downsample the clouds. I guess it should better not be used with octomapping, might work though. Have you set the "store_pointclouds" parameter to false? It is true by default.

Felix Endres gravatar imageFelix Endres ( 2017-03-20 11:11:03 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-02 13:09:30 -0600

I have a same problem. Although i set "store_pointclouds" to false, the saved octomap file has no data. The saved octomap just include as follows.

# Octomap OcTree file
# (feel free to add / change comments, but leave the first line as it is!)
#
id ColorOcTree
size 0
res 0.5
data

I just click "Save Octomap" in the menu without clicking any other menu. I'm working on Ubuntu 16.04, Kinectic and rgbdslam v2 ( https://github.com/felixendres/rgbdsl... )

Thank you.

edit flag offensive delete link more

Comments

1

I solved this issue by adding return true in bool GraphManager::updateCloudOrigin(Node* node). This function needs to return a bool but return true is missed in the end of the function. The function can be found in graph_mgr_io.cpp. I finally have a binary octomap file.

robotsoft gravatar imagerobotsoft ( 2017-06-05 17:14:42 -0600 )edit

Not solving I have tried to set the store_pointclouds option to false and then tried your method nothing changes

Dhagash Desai gravatar imageDhagash Desai ( 2017-09-30 16:03:13 -0600 )edit

You may try with setting store_pointclouds to true. It is helpful to post your saved octomap for solving this problem.

robotsoft gravatar imagerobotsoft ( 2017-10-02 11:37:22 -0600 )edit

Thanks for the above answer the return true thing worked I got binary octomap

Dhagash Desai gravatar imageDhagash Desai ( 2018-02-19 11:31:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-02-02 10:23:33 -0600

Seen: 300 times

Last updated: Feb 02 '17