Ask Your Question
0

virtual machine master to robotic armv7 node communication issues

asked 2017-01-31 13:25:59 -0500

w gravatar image

updated 2017-02-01 05:21:45 -0500

gvdhoorn gravatar image

running a virtual machine as the master and having trouble getting rostopic to get data.

always asks if my messages are built.

Is there a way to confirm that they are built?


Edit: I noted my question was vague without details...

I attempt

rostopic ech /turtle1/cmd_vel

Response:

ERROR: Cannot load message class for [geometry_msgs/Twist]. Are your messages built?

Some googling says I should be able to run sudo netcat from both directions, but I can only do it one way..... still working on it.....

if I run (on virtual Machine MASTER (lvbuser001-VirtualBox)): sudo netcat -l 1234

and run (on ARMv7 (chip)): sudo netcat lvbuser001-VirtualBox 1234

it works!

if I run (on ARMv7 (chip)): sudo netcat -l 1234

and run (on virtual Machine MASTER): sudo netcat chip 1234

it fails!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-01 05:25:47 -0500

gvdhoorn gravatar image

Make sure everything discussed in wiki/ROS/NetworkSetup works correctly.

From the test you describe it could be that:

  1. your VM is using a NAT-ed network connection (essentially one-way traffic)
  2. you don't have a working DNS for all involved hosts
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-01-31 13:25:59 -0500

Seen: 45 times

Last updated: Feb 01 '17