ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Indigo: build from source on C.H.I.P. fails: cc1plus killed

asked 2017-01-31 10:15:16 -0500

w gravatar image

updated 2017-01-31 13:32:33 -0500

gvdhoorn gravatar image

I am using this set of instructions.........

sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo

Errors out in step 41 of 48

c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.9/README.Bugs> for instructions.
CMakeFiles/roscpp.dir/build.make:146: recipe for target 'CMakeFiles/roscpp.dir/src/libros/publisher_link.cpp.o' failed
make[2]: *** [CMakeFiles/roscpp.dir/src/libros/publisher_link.cpp.o] Error 4
CMakeFiles/Makefile2:317: recipe for target 'CMakeFiles/roscpp.dir/all' failed
make[1]: *** [CMakeFiles/roscpp.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
<== Failed to process package 'roscpp':
  Command '['/opt/ros/indigo/', 'make', '-j1', '-l1']' returned non-zero exit status 2

Reproduce this error by running:
==> cd /home/chip/ros_catkin_ws/build_isolated/roscpp && /opt/ros/indigo/ make -j1 -l1

Command failed, exiting.
chip@chip:~/ros_catkin_ws$ sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indig

Edit: I apologize, i honestly didn't know where to look. for precompiled binaries... Any hints?

I was perhaps under the mistaken impression that they did not exist.

Debian Wheezy (7.5)

There are no precompiled binaries of ROS for Debian, while it seems that most of the dependencies are being pulled into the main repositories there are still some missing so compiling requires that the dependencies be made from source as well. The following steps describe how to compile everything from source doing this for a machine running Debian Wheezy.

I don't know when this was written so perhaps it is out of date.

NOTE: I am on a Debian Jessie platform......

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-01-31 11:47:15 -0500

gvdhoorn gravatar image

updated 2017-01-31 13:26:54 -0500


From this, I have the impression you are attempting this on an ARM platform. Those are typically resource limited, and compilation of (heavily templated) C++ sources is a resource intensive process. c++: internal compiler error: Killed (program cc1plus) can then often be caused by the system running out-of-memory.

Can you try to reduce the paralellisation by adding -j1 to your catkin_make_isolated call?


I apologize, i honestly didn't know where to look. for precompiled binaries... Any hints?

I'm not sure, but you could perhaps use the packages in the Debian repositories part of the DebianScience/Robotics project. They won't have everything, and the versions are fixed (ie: they don't track upstream), but depending on your use-cases it could allow you to avoid a lot of compiling.

edit flag offensive delete link more


I thank you for the suggestion and have tried exactly that but it still fails, yes it is an arm platform .

w gravatar image w  ( 2017-01-31 12:29:04 -0500 )edit

Can you provide a bit more information? How much memory does it have? What platform is this? Do you have swap enabled?

gvdhoorn gravatar image gvdhoorn  ( 2017-01-31 12:46:50 -0500 )edit

i am using a nextthing chip (($9). I was running the version with the gui enabled. I tried to get it to compile multiple times, it always failed out at the same step. I flashed to a headless image and am reattempting, with the thought that perhaps this will free up enough system resources to complet

w gravatar image w  ( 2017-01-31 12:58:03 -0500 )edit

e the task. will update as to my progress, thank you for your assistance

w gravatar image w  ( 2017-01-31 12:58:36 -0500 )edit

Looks like it has only 512MB of ram. C++ compilers are very ram hungry beasts. If you have the skills, I'd look into cross-compilation.

Also looks like it's an ARMv7 device. Have you checked whether you can use any of the pre-built binary distributions?

gvdhoorn gravatar image gvdhoorn  ( 2017-01-31 13:02:07 -0500 )edit

The installation was successful on the headless (non GUI) image. Thank you for your time and knowledge. ONWARD to the next Battle!

w gravatar image w  ( 2017-01-31 14:31:02 -0500 )edit

Question Tools

1 follower


Asked: 2017-01-31 10:15:16 -0500

Seen: 227 times

Last updated: Jan 31 '17