Ask Your Question
0

/opt/ros/kinetic/setup.bash: No such file or dirctory

asked 2017-01-30 09:47:03 -0500

malgudi gravatar image

I am trying to install ROS on raspberry pi 2 model b. The ubuntu-mate 16.04 OS is installed. During environment setup I am getting /opt/ros/kinetic/setup.bash: No such file or dirctory error.

Whats the solution?

Thank You.

edit retag flag offensive close merge delete

Comments

Are you sure the earlier commands completed successfully? If you don't have that file, I fear that you haven't installed ROS at all.

gvdhoorn gravatar imagegvdhoorn ( 2017-01-30 11:24:57 -0500 )edit

Well I tried to install it again everything from start, there was problem in installing rosdep then i followed #q32875 this page but I again i faced same problem during environment setup.

Can I install Indigo ROS on ubuntu-mate 16.04??

malgudi gravatar imagemalgudi ( 2017-01-31 00:24:46 -0500 )edit

Indigo officially does't Ubuntu 16.04 link text Kinectic works fine on Raspberry Pi with Mate 16.04

S_Lzrnk gravatar imageS_Lzrnk ( 2017-01-31 03:20:04 -0500 )edit

As @S_Lzrnk mentions, Indigo is not supported on 16.04, but Kinetic should be. I'm not sure about RPi2 binary builds though.

gvdhoorn gravatar imagegvdhoorn ( 2017-01-31 03:26:36 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-01-31 21:05:24 -0500

malgudi gravatar image

updated 2018-04-05 08:11:17 -0500

jayess gravatar image

HI... I got the solution. If you use the command

sudo apt-get update --fix-missing

this will solve the problem.

edit flag offensive delete link more

Comments

not fixing the problem for me for same error

1at7 gravatar image1at7 ( 2019-08-02 06:02:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-01-30 09:47:03 -0500

Seen: 1,705 times

Last updated: Apr 05 '18