ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

error launching moveitsetup assistant

asked 2017-01-24 02:38:55 -0500

motoman gravatar image

updated 2017-01-24 03:07:50 -0500

gvdhoorn gravatar image

On launching move it setup assistant, I get an error message saying that the process has died. I have used

sudo apt-get install ros-indigo-moveit

source /opt/ros/indigo/setup.bash

to install and setup the environment. I have also used sudo apt-get update, unfortunately the error persists

amrith@amrith-ThinkPad-T420:~$ roslaunch moveit_setup_assistant setup_assistant.launch 
... logging to /home/amrith/.ros/log/273d2cf4-e20f-11e6-9bc2-0021cc4b3caa/roslaunch-amrith-ThinkPad-T420-6923.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://amrith-ThinkPad-T420:46293/

SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.20

NODES
  /
    moveit_setup_assistant (moveit_setup_assistant/moveit_setup_assistant)

auto-starting new master
process[master]: started with pid [6935]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 273d2cf4-e20f-11e6-9bc2-0021cc4b3caa
process[rosout-1]: started with pid [6948]
started core service [/rosout]
process[moveit_setup_assistant-2]: started with pid [6951]
/opt/ros/indigo/lib/moveit_setup_assistant/moveit_setup_assistant: error while loading shared libraries: libmoveit_robot_state_rviz_plugin_core.so.0.7.3: cannot open shared object file: No such file or directory
================================================================================REQUIRED process [moveit_setup_assistant-2] has died!
process has died [pid 6951, exit code 127, cmd /opt/ros/indigo/lib/moveit_setup_assistant/moveit_setup_assistant __name:=moveit_setup_assistant __log:=/home/amrith/.ros/log/273d2cf4-e20f-11e6-9bc2-0021cc4b3caa/moveit_setup_assistant-2.log].
log file: /home/amrith/.ros/log/273d2cf4-e20f-11e6-9bc2-0021cc4b3caa/moveit_setup_assistant-2*.log
Initiating shutdown!
================================================================================
[moveit_setup_assistant-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done
edit retag flag offensive close merge delete

Comments

can you please tell us how you installed ROS: I'm assuming from debs (ie: apt-get install ..)? And MoveIt? Also only using apt-get?

gvdhoorn gravatar imagegvdhoorn ( 2017-01-24 03:08:38 -0500 )edit

yes ! I installed ROS using apt-get and also the moveit setup assistant using apt-get

motoman gravatar imagemotoman ( 2017-01-24 04:43:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-01-30 10:26:51 -0500

gvdhoorn gravatar image

Turns out the OP had an inconsistent MoveIt installation (ie: different versions of the binary packages).

After installing all MoveIt packages with the same versions, things started working as they should.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-24 02:38:55 -0500

Seen: 631 times

Last updated: Jan 30 '17