Ask Your Question

*.cfg: permission denied while building workspace

asked 2017-01-23 21:21:53 -0600

Acecryz gravatar image

updated 2017-01-24 02:16:42 -0600

gvdhoorn gravatar image

I am making a custom robot for my final year project, for the robot to work, I was given a custom catkin_ws file. I followed the steps mention here

and after following the steps, this occurred.

ros@ros-desktop:~/catkin_ws$ catkin_make
Base path: /home/ros/catkin_ws
Source space: /home/ros/catkin_ws/src
Build space: /home/ros/catkin_ws/build
Devel space: /home/ros/catkin_ws/devel
Install space: /home/ros/catkin_ws/install
#### Running command: "make cmake_check_build_system" in "/home/ros/catkin_ws/build"
#### Running command: "make -j4 -l4" in "/home/ros/catkin_ws/build"
[  0%] [  0%] Built target _rosserial_arduino_generate_messages_check_deps_Test
Built target _rosserial_arduino_generate_messages_check_deps_Adc
[  0%] Built target _rosserial_msgs_generate_messages_check_deps_Log
[  0%] Built target _rosserial_msgs_generate_messages_check_deps_RequestParam
[  6%] Built target serial
[ 11%] Built target merlin_hostbot
[ 11%] [ 11%] Built target _rosserial_msgs_generate_messages_check_deps_RequestMessageInfo
Built target _rosserial_msgs_generate_messages_check_deps_TopicInfo
[ 11%] Built target _rosserial_msgs_generate_messages_check_deps_RequestServiceInfo
[ 13%] Built target quaternion2yaw_node
[ 16%] [ 20%] Built target stm_hostbot
Generating dynamic reconfigure files from cfg/CalibrateAngular.cfg: /home/ros/catkin_ws/devel/include/rbx1_nav/CalibrateAngularConfig.h /home/ros/catkin_ws/devel/lib/python2.7/dist-packages/rbx1_nav/cfg/
/home/ros/catkin_ws/build/rbx1/rbx1_nav/ 4: exec: /home/ros/catkin_ws/src/rbx1/rbx1_nav/cfg/CalibrateAngular.cfg: Permission denied
make[2]: * [/home/ros/catkin_ws/devel/include/rbx1_nav/CalibrateAngularConfig.h] Error 126
make[1]: * [rbx1/rbx1_nav/CMakeFiles/rbx1_nav_gencfg.dir/all] Error 2
make[1]: * Waiting for unfinished jobs....
[ 23%] [ 25%] Built target urg_c_wrapper
Generating dynamic reconfigure files from cfg/URG.cfg: /home/ros/catkin_ws/devel/include/urg_node/URGConfig.h /home/ros/catkin_ws/devel/lib/python2.7/dist-packages/urg_node/cfg/
/home/ros/catkin_ws/build/urg_node/ 4: exec: /home/ros/catkin_ws/src/urg_node/cfg/URG.cfg: Permission denied
make[2]: * [/home/ros/catkin_ws/devel/include/urg_node/URGConfig.h] Error 126
make[1]: * [urg_node/CMakeFiles/urg_node_gencfg.dir/all] Error 2
[ 27%] Built target user_publisher
make: * [all] Error 2
Invoking "make -j4 -l4" failed

Any help would be greatly appreciated, thanks

edit retag flag offensive close merge delete


I am only a beginner but the -j4 usually means use 4 cores on the processor. Could you try changing -j4 to -j1

burf2000 gravatar image burf2000  ( 2017-01-24 02:11:39 -0600 )edit

I've updated the title of your question to better reflect what is the problem (and to also differentiate it a bit from the million other "make -j4 -l4 failed" questions.

gvdhoorn gravatar image gvdhoorn  ( 2017-01-24 02:17:32 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-01-24 02:13:04 -0600

gvdhoorn gravatar image

updated 2017-01-24 02:16:14 -0600

/home/ros/catkin_ws/build/rbx1/rbx1_nav/ 4: exec: /home/ros/catkin_ws/src/rbx1/rbx1_nav/cfg/CalibrateAngular.cfg: Permission denied
/home/ros/catkin_ws/build/urg_node/ 4: exec: /home/ros/catkin_ws/src/urg_node/cfg/URG.cfg: Permission denied

have you extracted these files from a zip file, or copied them from a usb stick or Windows share?

Those .cfg files (they are files for dynamic_reconfigure) should have their executable bit set, and they currently probably don't have it, that's why you get the Permission denied errors.

Try and see what the output is of:

ls -al /home/ros/catkin_ws/src/rbx1/rbx1_nav/cfg/CalibrateAngular.cfg


ls -al /home/ros/catkin_ws/src/urg_node/cfg/URG.cfg

If it doesn't include the x bit for both you and other users, then do a:

chmod +x /home/ros/catkin_ws/src/rbx1/rbx1_nav/cfg/CalibrateAngular.cfg


chmod +x /home/ros/catkin_ws/src/urg_node/cfg/URG.cfg

and try again.


[..] I was given a custom catkin_ws file.

Pedantic perhaps, but note that 'catkin_ws' is typically a directory, not a single file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-01-23 21:21:53 -0600

Seen: 5,523 times

Last updated: Jan 24 '17