Problem with urg_node: Unknown error connecting to Hokuyo

asked 2017-01-11 05:52:56 -0600

nico_b gravatar image

Hi,
when I run rosrun urg_node urg_node I get the output [ERROR] [1484133582.989584109]: Unknown error connecting to Hokuyo.
Since the hokuyo_node is the previous version of the urg_node, I git cloned (indigo) it. When running rosrun hokuyo_node hokuyo_node I get the expected result:

[ INFO] [1484134681.274676697]: Connected to device with ID: H0613892
[ INFO] [1484134681.373417311]: Starting calibration. This will take up a few seconds.
[ INFO] [1484134684.471015665]: Calibration finished. Latency is: -0.0821
[ INFO] [1484134684.785325646]: Streaming data.

In both cases I run previously sudo chmod a+rw /dev/ttyACM0.
When I run rosrun urg_node urg_node now (without previously shutting down the laser scanner and running the hokuyo_node first) I get as expected:

[ INFO] [1484134914.006785798]: Connected to serial device with ID: H0613892
[ INFO] [1484134914.946978579]: Streaming data.

So, I guess, when calling the hokuyo_node first, some bit is set and therefore a can use the urg_node.
Do you have any idea, how I may run urg_node without running hokuyo_node first (since hokuyo_node is outdated)? How can I set that given bit?
I'm using an URG-04LX.
Thanks in advance.

edit retag flag offensive close merge delete