Ask Your Question
0

Why can't I launch amr-ros-config-master and ROSARIA?

asked 2017-01-11 05:02:00 -0600

edmond320 gravatar image

Hello everyone

Recently I've been trying to connect ROSARIA and AdeptMobileRobots.I have downloaded amr-ros-config-master file from [ https://github.com/MobileRobots/amr-r... ], however,when I launch this launched file,the following error came:

Invalid <arg> tag: amr_robots_description

ROS path [0]=/opt/ros/indigo/share/ros

ROS path [1]=/opt/ros/indigo/share

ROS path [2]=/opt/ros/indigo/stacks

Arg xml is arg default="$(find amr_robots_description)/urdf/pioneer3dx.urdf" name="urdf"/

The traceback for the exception was written to the log file

ANYONE can help me??? THANKS VERY MUCH.

edit retag flag offensive close merge delete

Comments

Hello, are you trying to use one of the launch files? If so which one, what is the exact command you are using, and what is the output of that? The amr-ros-config repository contains ROS packages, which must be in the ROS package path. (e.g. the src directory of a catkin workspace)

ReedHedges gravatar imageReedHedges ( 2017-03-13 09:10:48 -0600 )edit

I am also getting the same error. The command is: roslaunch rosaria.launch and the output is exactly as shown in the question. The packages have been cloned into the src directory and properly built through catkin_make at the base catkin path

bongzaseko gravatar imagebongzaseko ( 2017-03-24 03:50:33 -0600 )edit

bongzaseko: Is amr-ros-config in the src directory? did you run . devel/setup.bash or similar in the catkin workspace? What is the output of rospack find amr_robots_description? What version of ROS are you using? Also indigo?

ReedHedges gravatar imageReedHedges ( 2017-03-24 08:49:30 -0600 )edit

This has been sorted on my side, I hadn't followed the tutorial on rosaria setup properly. After redoing it the error went away, now i can startup the rosaria node. Yes I am using Indigo on Ubuntu 14.04

bongzaseko gravatar imagebongzaseko ( 2017-03-24 09:23:51 -0600 )edit

Can you write an answer below with a quick explanation? Which step in the rosaria tutorial fixed it?

ReedHedges gravatar imageReedHedges ( 2017-03-24 09:45:23 -0600 )edit

OK, I will do so in a few moments. Let me draft it.

bongzaseko gravatar imagebongzaseko ( 2017-03-24 10:38:54 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-03-24 12:15:56 -0600

bongzaseko gravatar image

I experienced the same problem and got it cleared by redoing the ROSARIA setup using the instructions in http://wiki.ros.org/ROSARIA/Tutorials... . I started from the "Bring ROSARIA into the workspace" section since I already had ROS installed and my catkin workspace setup. Under the next section(Install ARIA and Build ROSARIA), I installed the ARIA dependecy using the given rosdep commands, and after that built ROSARIA using the --force-cmake option on catkin_make as advised. I then proceeded successfully with all the following steps in this tutorial on starting the rosaria node and publishing as well as with running the roslaunch rosaria.launch file from the amr_robots_launchfiles package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-01-11 05:02:00 -0600

Seen: 195 times

Last updated: Mar 24 '17