Ask Your Question

ROS Indigo on Raspberry Pi 3 urdf_model/utils.h: No such file

asked 2016-12-29 07:33:41 -0600

Ilya Boyur gravatar image

updated 2016-12-30 01:12:32 -0600

Hi everyone, I have such a uncommon problem and haven't found solution yet. I am followed instructions on ROSberry Pi to install ROS Indigo on Raspberry Pi 3. I used ros_comm (Bared Bones) on Raspbian Jessie Lite . I am using package ur_modern_driver, so in a nutshell it turned out, that it requires some extra packages to operate, also it needs "liburdfdom-dev". So I followed instructions from ROSberry Pi mentioned above to install that package from source. Firstly, urdfdom-headers-dev didn't compile with "cmake ." so it showed that version problem, which I solved with "git reset --hard 9aed725". Eventually, when I tried to "sudo checkinstall make install" with "liburdfdom-dev", it crashed: urdf_model_state.cpp:39:30 fatal error: urdf_model/utils.h: no such file or directory. Actually, this is saying, that I shouldn't do "git reset --hard 9aed725" in the first place, but it wouldn't work, as I mentioned. So have anyone met and solved the same problem?

edit retag flag offensive close merge delete


And yes, according to ROSberry Pi this package should be installed by APT tool for Raspbian Jessie, but it doesn't. So that is why the question is so uncommon.

Ilya Boyur gravatar image Ilya Boyur  ( 2016-12-30 01:12:37 -0600 )edit

I attempted ROS on Raspbian and then discovered ROS Kinetic supports Ubuntu server natively on RPi3. There is no need to install from source for most ROS packages.

If you have the option, the ubuntu 16.04 (xenial) for RPi3 could save you much effort. The key is the "armhf" support.

suforeman gravatar image suforeman  ( 2016-12-31 07:10:12 -0600 )edit

suforeman, the point was to use Raspbian, cause it's native to RPi3 and supports ROS Indigo. Ubuntu 16.04 is not supported for Indigo. I've heard about Ubuntu 16.04 usage with Docker on Ubuntu 14.04, It's seems quite tricky

Ilya Boyur gravatar image Ilya Boyur  ( 2017-01-09 03:02:01 -0600 )edit

Ubuntu 16.04 (xenial) for RPi3 doesn't support Docker (problem is because Docker needs arm64 ubuntu version), so that is not an option. There is no image of Ubuntu 14.04 for Raspberry Pi 3.

Ilya Boyur gravatar image Ilya Boyur  ( 2017-01-10 04:14:39 -0600 )edit

Understand now. This may be a case of "which is less painful". Is it harder to build ROS on Raspbian arm64 or get Docker on armhf. There appears to be some movement on the latter scenario:

suforeman gravatar image suforeman  ( 2017-01-10 06:11:36 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2017-03-15 02:50:30 -0600

Ilya Boyur gravatar image

Actually, I left the idea to use ROS Indigo on Rasbian OS because of a lot uncompatibility with other ROS packages I needed, such as universal_robot, ur_modern_driver and dependencies. So I suggest to use Kinetic with Raspbian from now on.

edit flag offensive delete link more

answered 2017-01-11 10:28:19 -0600

km gravatar image

Have the same problem, tried it twice (I copied the utils.h file the 2nd time in the urdf_model folder). Didn't work...Hope someone comes up with a solution...I guess the "git reset --hard 9aed725" command was wrong...didn't try that without though.

Update: installing the liburdfdom-dev (=liburdfdom-headers-dev) accoding to and NOT using "git reset --hard 9aed725" works!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2016-12-29 07:33:41 -0600

Seen: 773 times

Last updated: Mar 15 '17