razor_imu_9dof quaternion fault

asked 2016-12-27 08:40:27 -0600

wiebe gravatar image

updated 2016-12-29 04:51:00 -0600

hi,

I am working with the 9dof razor imu on the jetson tx1. I have installed the ros package ros-kinetic-razor-imu-9dof and calibrate the sensor. I ran razor-pub-and-display and everything seems good. When I look in rviz the sensor turns but at the south the boat jump 45 degrees. At the same moment the rostopic /imu values change form z: 0.99, w: 0.00 to z: -0.99, w: 0.00. It looks to me this is a Math problem. Has anyone encountered the same problem. How to solve this?

This happens if you run both programs.

image description

edit retag flag offensive close merge delete

Comments

Can you please attach images to the question directly?

Thanks

gvdhoorn gravatar image gvdhoorn  ( 2016-12-27 11:17:24 -0600 )edit

I think something didn't work when you attached the image. It still links to postimg.org.

gvdhoorn gravatar image gvdhoorn  ( 2016-12-28 04:13:49 -0600 )edit

I can't upload a gif image...

wiebe gravatar image wiebe  ( 2016-12-29 04:50:33 -0600 )edit

Seems that is indeed not allowed. Embedding is apparently also doesn't work. @tfoote?

gvdhoorn gravatar image gvdhoorn  ( 2016-12-29 05:02:39 -0600 )edit

Have not seen this, does this also happen without calibration? Did you try a new calibration?

Humpelstilzchen gravatar image Humpelstilzchen  ( 2017-01-01 10:45:27 -0600 )edit

Yes I have calibrate the sensor two times but still the same problem occurs and if I use the factory setting it's exactly the same...

wiebe gravatar image wiebe  ( 2017-01-01 12:02:12 -0600 )edit