Ask Your Question

Error "FindEigen3.cmake" during install kinetic on RPi

asked 2016-12-25 10:41:06 -0500

AleAle99 gravatar image

updated 2016-12-29 04:58:56 -0500

gvdhoorn gravatar image

hi all

first: marry christmas

second : I'm not skilled about install a so large enviroment|software ... so I followed the wiki : install Kinect on raspberry ROS Kinetic on the Raspberry Pi and at point 3.3 Building the catkin Workspace I have got this error

    ==> Processing catkin package: 'geometric_shapes' 
==> Creating build directory: 'build_isolated/geometric_shapes' 
==> Building with env: '/opt/ros/kinetic/' 
==> cmake /home/pi/ros_catkin_ws/src/geometric_shapes -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/geometric_shapes -DCMAKE_INSTALL_PREFIX=/op
t/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles in '/home/pi/ros_catkin_ws/build_isolated/geometric_shapes' 
-- The C compiler identification is GNU 4.9.2 
-- Boost version: 1.55.0 
-- Found the following Boost libraries: 
--   system 
--   filesystem 
CMake Error at CMakeLists.txt:24 (find_package): 
 By not providing "FindEigen3.cmake" in CMAKE_MODULE_PATH this project has 
 asked CMake to find a package configuration file provided by "Eigen3", but 
 CMake did not find one. 

 Could not find a package configuration file provided by "Eigen3" with any 
 of the following names: 


I've read many posts, but it is unclear for me which cmakelist.txt edit and how to fix it.

edit retag flag offensive close merge delete


Did you fix this as I have the same issue

burf2000 gravatar image burf2000  ( 2017-01-06 10:33:57 -0500 )edit

burf2000 Sorry, still no solution .... and unfortunately no idea about what to do!

AleAle99 gravatar image AleAle99  ( 2017-01-07 03:16:53 -0500 )edit

3 Answers

Sort by » oldest newest most voted

answered 2017-01-07 06:48:35 -0500

burf2000 gravatar image

updated 2017-01-09 03:55:55 -0500

So my workaround for this was to find anywhere where find_package(Eigen3 REQUIRED) is included in CMakeList.txt in the src directory (In each package)

and replace with

find_package(Eigen3 REQUIRED)

Second, Find a copy of the FindEigen3.cmake file and copy it to the same place as the CMakeList.txt. I found it in another package.

edit flag offensive delete link more


GREAT! and to find the string in each CMakeList.txt can I use a linux command or you did it manually? are many files to be changed?

thanks! Ale

AleAle99 gravatar image AleAle99  ( 2017-01-07 12:10:23 -0500 )edit

something like this is right ???

grep -r -i "find_package(Eigen3 REQUIRED)" /home/pi/ros_catkin_ws/
AleAle99 gravatar image AleAle99  ( 2017-01-07 12:30:10 -0500 )edit

i modified 2 files:

~/ros_catkin_ws $ grep -r -i "find_package(Eigen3 REQUIRED)" ~/ros_catkin_ws/

~/ros_catkin_ws/src/robot_state_publisher/CMakeLists.txt:find_package(Eigen3 REQUIRED) ~/ros_catkin_ws/src/geometric_shapes/CMakeLists.txt:find_package(Eigen3 REQUIRED)

but same error!!!

AleAle99 gravatar image AleAle99  ( 2017-01-07 14:04:37 -0500 )edit

updated dude :)

burf2000 gravatar image burf2000  ( 2017-01-09 03:56:02 -0500 )edit

hI BURF2000

I copied the file FindEigen3.cmake near the two CMakeLists.txt previously modified in the packages ~/ros_catkin_ws/src/robot_state_publisher/ ~/ros_catkin_ws/src/geometric_shapes/

but the error is the same.

AleAle99 gravatar image AleAle99  ( 2017-01-13 09:28:32 -0500 )edit

Followed the instructions verbatim (for desktop install not ROS-comm) and have the same issue. This answer fixed my issue. Thanks fo that. Here is a slightly quicker grep command. ~/ros_catkin_ws $ grep -ri "find_package(Eigen3 REQUIRED)" . --include '*CMakeLists.txt'

HappyPaul gravatar image HappyPaul  ( 2017-04-02 15:39:55 -0500 )edit

answered 2016-12-29 03:04:02 -0500

bluking gravatar image

sudo apt-get install libeigen3-dev

edit flag offensive delete link more


ty bluking the lib is present

pi@pizero:~ $ sudo apt-get install libeigen3-dev Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto libeigen3-dev è già alla versione più recente.

AleAle99 gravatar image AleAle99  ( 2016-12-29 11:37:32 -0500 )edit

answered 2017-01-08 02:43:31 -0500

newma gravatar image

Well, I also encounter this error on my RPI3. Even when I installed the libeigen3-dev, the error still there.

edit flag offensive delete link more


Yes, even though its installed you need to update everywhere it asks for find_package(Eigen3 REQUIRED)

burf2000 gravatar image burf2000  ( 2017-01-09 03:56:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-12-25 10:41:06 -0500

Seen: 2,251 times

Last updated: Jan 09 '17