Ask Your Question
2

The Kinematics plugin (manipulator) failed to load

asked 2016-12-22 13:40:19 -0600

jbeck28 gravatar image

updated 2016-12-22 14:20:18 -0600

gvdhoorn gravatar image

I've been trying to get ROS to work with a fanuc 200id, and I'm running into an error whenever I try to run this section of code:

roslaunch fanuc_lrmate200id_moveit_config moveit_planning_execution.launch sim:=false robot_ip:=10.0.0.93

The error it generates is as follows:

[ERROR] [1482361035.715386305]: The kinematics plugin (manipulator) failed to load. Error: Failed to load library /home/rnd/catkin_ws/devel/lib//libfanuc_lrmate200id_manipulator_moveit_ikfast_plugin.so. Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = libmoveit_kinematics_base.so.0.9.1: cannot open shared object file: No such file or directory)
[ERROR] [1482361035.715445991]: Kinematics solver could not be instantiated for joint group manipulator.

I'm not really sure how to proceed, any help would be appreciated.

thanks

edit retag flag offensive close merge delete

Comments

Can you please add which version of ROS this is, on which OS, how you installed both ROS and your OS, etc? I'm also guessing that you're building the entire Fanuc set of packages from sources? Please tell us how you setup your workspace in that case.

gvdhoorn gravatar imagegvdhoorn ( 2016-12-22 14:21:22 -0600 )edit

The "Poco exception" makes me suspect that you built the Fanuc packages some time ago, then updated MoveIt and did not rebuild your workspace. The sonames were added to MoveIt quite recently, and were added to avoid ABI problems by basically 'breaking' ppl's workspaces.

gvdhoorn gravatar imagegvdhoorn ( 2016-12-22 14:26:28 -0600 )edit

I installed Ubuntu 16.04 from a USB drive, and installed ROS by following the tutorial here: http://wiki.ros.org/kinetic/Installat... I built the Fanuc_indigo_experimental packages not long after installing ROS itself, perhaps a few weeks had elapsed at most.

jbeck28 gravatar imagejbeck28 ( 2016-12-27 15:14:22 -0600 )edit

I setup my catkin workspace by following this tutorial: http://wiki.ros.org/ROS/Tutorials/Cre... I placed the fanuc experimental packages in the src folder inside catkin_ws.

Thanks for your help so far, let me know if there's anymore information I can provide.

jbeck28 gravatar imagejbeck28 ( 2016-12-27 15:15:17 -0600 )edit

Ok. And seeing as you have Kinetic installed: did you build MoveIt from sources as well?

gvdhoorn gravatar imagegvdhoorn ( 2016-12-28 01:58:39 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-12-28 02:07:23 -0600

gvdhoorn gravatar image

Because of the Poco exception ("file not found") I believe this is due to partial updating and / or not rebuilding a workspace after having updated ROS.

If you build packages from sources, you are required to rebuild your workspace every time you update any of the binaries that you depend on (for now, as there is no ABI compatibility guarantee). In most cases, failing to do this results in SEGFAULTs, but the MoveIt developers added something called sonames which are intended to result in exactly the error you ran into: instead of hard to debug SEGFAULTs, binaries will now refuse to load as libraries they require cannot be found.

The way to deal with this is to rebuild your workspace. Just run catkin_make (or catkin build) as you normally would and things should start working again.

Note btw that the fanuc_experimental packages are known not to completely work on Kinetic. See ros-industrial/fanuc#199. I'm surprised you got the kinematics plugins to build on Kinetic at all.

edit flag offensive delete link more

Comments

I ran catkin_make and I'm still encountering the same error. Perhaps this is related to some greater incompatibility with Kinetic? In order to get any of the fanuc packages to build, I had to add a line to each of the cmake.lists which forced it to compile using c++11.

jbeck28 gravatar imagejbeck28 ( 2016-12-28 09:49:54 -0600 )edit

Do you think I might be better served by simply installing a previous ubuntu version and running indigo?

jbeck28 gravatar imagejbeck28 ( 2016-12-28 09:50:49 -0600 )edit

re: downgrading to Indigo: that would get you to a known-working setup, yes.

re: still have the same problem: please try removing your build and devel folder in your workspace, then rebuild it. I've just tested building fanuc_experimental on Kinetic, and it will definitely link correctly.

gvdhoorn gravatar imagegvdhoorn ( 2016-12-28 10:41:40 -0600 )edit

Note that I purposefully not wrote "work correctly", as I haven't tested the packages.

Can you please confirm whether you have a from-sources MoveIt installation on your Kinetic install?

gvdhoorn gravatar imagegvdhoorn ( 2016-12-28 10:42:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-12-22 13:40:19 -0600

Seen: 1,299 times

Last updated: Dec 28 '16