swiftnav dGPS not receiving data

asked 2016-12-21 17:42:16 -0600

Sam94 gravatar image

updated 2016-12-21 23:38:09 -0600

The swiftnav_piksi driver will connect, but nothing is published to the /gps/ topics. I have tried it using simulation mode and outdoors, but it does not work either way. The diagnostics show that no satellites are in view even though the flashing light on the piksi indicated that it could see 7.

Is this possibly a firmware incompatibility issue? Currently, STM v 0.21 and NAP v0.16 are installed.

I am running Indigo on Ubuntu 14.04.

edit retag flag offensive close merge delete

Comments

Is everything working as expected when you use the piksi outside of ROS? When you're just using the software that comes with the piksi?

Airuno2L gravatar imageAiruno2L ( 2016-12-22 06:14:32 -0600 )edit

It is working with v0.29 of the software. When we tried to use v0.31, we were able to view the positions and get a fixed RTK lock, but not record data (clicking the CSV Log button did not store the files).

Sam94 gravatar imageSam94 ( 2016-12-22 08:51:01 -0600 )edit