Ask Your Question
0

RTAB-map double walls

asked 2016-12-21 07:53:50 -0500

gijsje170 gravatar image

updated 2016-12-23 01:07:11 -0500

I just keep getting double walls in rtabmap when using it on my robot. I am using a Kinect to map the building. Settings: http://pastebin.com/CDtTe0JV

The result:

image description

EDIT in response to matlabbe: My odometry source is from the create_autonomy using the roomba 780. I know it has a reasonable drift. The launchfile I am using is RGBD_mapping.launch http://pastebin.com/q6B3S6HD

edit retag flag offensive close merge delete

Comments

What is your odometry source? and which launch file are your using (copy/paste stuff related to rtabmap here)?

matlabbe gravatar image matlabbe  ( 2016-12-22 14:17:08 -0500 )edit

Edited the main question

gijsje170 gravatar image gijsje170  ( 2016-12-23 01:07:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-01-04 12:32:31 -0500

matlabbe gravatar image

updated 2017-01-05 12:13:26 -0500

Hi,

if the laser scans are fake laser scans from Kinect, I don't recommend using them for ICP refining (causing more errors as they are not very precise with small FOV). Set --Reg/Strategy 0 --RGBD/NeighborLinkRefining false in rtabmap_args. I see some jumps in odometry. What happens if you disable loop closure detection by adding this --Kp/MaxFeatures -1 to rtabmap_args? The odometry should be smooth, if there are still jumps, there is a problem with odometry. Otherwise it may because of loop closure detection. Try with --Vis/MaxDepth 3.5 to limit the distance of features used for loop closure transformation (features over 4 meters are very noisy with Kinect v1).

EDIT

For loop closure, you can also try increasing --Vis/MinInliers 30 or re-extract features when computing the transformation --RGBD/LoopClosureReextractFeatures true, you may also want to disable --RGBD/ProximityBySpace false to avoid adding constraints with the fake laser scans.

cheers

edit flag offensive delete link more

Comments

I changed the parameters you said and did not really see an improvement. For some reason it saw a loop closure at the wrong time ruining the whole scan. Then I disabled loop closures and actually it worked quite well. Except for the fact that my odometry is really bad.

gijsje170 gravatar image gijsje170  ( 2017-01-05 02:34:41 -0500 )edit

I will improve the odometry of my robot and show you the results / improvements when done.

gijsje170 gravatar image gijsje170  ( 2017-01-05 02:35:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-12-21 07:53:50 -0500

Seen: 515 times

Last updated: Jan 05 '17