Ask Your Question
0

Nav2d Mapper does not produce map with turtlebot [closed]

asked 2016-12-19 10:43:23 -0500

alhouty808 gravatar image

Hello,

I have done the four tutorial of Nav2d package using stage simulator with success. then, i did tutorial 1 using my Turtlebot, the operator works perfectly and the costmap has no problem. However, i tried to do tutorial 3.The mapper did not produce map but the cost map exists. I noticed that when i call /StartMapping, the robot will only travel for 1 m without doing 360°. Below you can find all the needed information.

tf tree

rqt_graph

RVIZ screenshot

costmap

image description

map

image description

Launch File

<launch>


<rosparam file="$(find nav2d_tutorials)/param/ros.yaml"/>




<!-- Start the Operator to control the simulated robot -->
<node name="Operator" pkg="nav2d_operator" type="operator" >

    <remap from="cmd_vel" to="mobile_base/commands/velocity"/>
    <rosparam file="$(find nav2d_tutorials)/param/operator.yaml"/>
    <rosparam file="$(find nav2d_tutorials)/param/costmap.yaml" ns="local_map" />
</node>

<!-- Start Mapper to genreate map from laser scans -->
<node name="Mapper" pkg="nav2d_karto" type="mapper">

    <rosparam file="$(find nav2d_tutorials)/param/mapper.yaml"/>
</node>

<!-- Start the Navigator to move the robot autonomously--> 
<node name="Navigator" pkg="nav2d_navigator" type="navigator">
    <rosparam file="$(find nav2d_tutorials)/param/navigator.yaml"/>
</node>

<node name="GetMap" pkg="nav2d_navigator" type="get_map_client" />
<node name="Explore" pkg="nav2d_navigator" type="explore_client" />
<node name="SetGoal" pkg="nav2d_navigator" type="set_goal_client" />



<!-- RVIZ to view the visualization -->
<node name="RVIZ" pkg="rviz" type="rviz" args=" -d $(find nav2d_tutorials)/param/tutorial3.rviz" />

</launch>

ros.yaml

# Defines topics services and frames for all modules

### TF frames #############################################
laser_frame: laser
robot_frame: base_link
odometry_frame: odom
offset_frame: offset
map_frame: map

### ROS topics ############################################
map_topic: map
laser_topic: scan

### ROS services ##########################################
map_service: static_map

mapper.yaml

### Mapper ################################################

grid_resolution: 0.1
range_threshold: 10.0
map_update_rate: 5
publish_pose_graph: true
max_covariance: 0.01
transform_publish_period: 0.1
min_map_size: 20

### Localizer #############################################

min_particles: 2500
max_particles: 10000

### Karto #################################################

# For a full list of available parameters and their
# corresponding default values, see OpenKarto/OpenMapper.h

MinimumTravelDistance: 1.0
MinimumTravelHeading: 0.52
LoopSearchMaximumDistance: 10.0

###########################################################

Thank you in advance,

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by alhouty808
close date 2016-12-19 23:23:57.068846

1 Answer

Sort by » oldest newest most voted
0

answered 2016-12-19 23:23:27 -0500

alhouty808 gravatar image

Solved by replacing the parameter of "laser_frame: laser" to "laser_frame: camera_link" in ros.yaml.

Thank you all,

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-12-19 10:43:23 -0500

Seen: 306 times

Last updated: Dec 19 '16