Pointcloud_to_laserscan complications

asked 2016-12-19 05:14:54 -0600

DragosCr gravatar image

updated 2016-12-19 06:10:54 -0600

Hello, I am trying to use the pointcloud_to_laserscan library with very little success.I had some kind of results but now i can't see anything in rviz.The results that i am speeching about are just a few points not really related to the cloud information. I tried to "play" with the angle_increment param to increasing the resolution of the output laser. i did not obtain good results, 2 independent and very small( i guess sized down in a way) lasers in rviz. After this a clean install the library again, but now nothing is visible in rviz. I changed the target frame param, with no results. I am just hoping that maybe somebody had the same situation like I do and can give me a bit of info on how can this be solved. I can't use depthimage_to_laserscan because i need to filter the point cloud before obtaining the final laserscan. Depthimage_to_laserscan works with no problem. Any help is highly appreciated.

This is the launch file that i run the pointcloud_to_laserscan node:

<?xml version="1.0"?>

<launch>

    <arg name="camera" default="camera" />

    <!-- start sensor-->
    <include file="$(find openni2_launch)/launch/openni2.launch">
        <arg name="camera" default="$(arg camera)"/>
    </include>

    <!-- run pointcloud_to_laserscan node -->
    <node pkg="pointcloud_to_laserscan" type="pointcloud_to_laserscan_node" name="pointcloud_to_laserscan">

        <remap from="cloud_in" to="/filtered"/>
        <remap from="scan" to="$(arg camera)/scan"/>
        <rosparam>
            target_frame:camera_link # Leave disabled to output scan in pointcloud frame
            transform_tolerance: 0.5
            min_height: 0.0
            max_height: 4.0

            angle_min: -1.5708 # -M_PI/2
            angle_max: 1.5708 # M_PI/2
            angle_increment: 0.0087 # M_PI/360.0
            scan_time: 0.3333
            range_min: 0.2
            range_max: 4.0
            use_inf: true

            # Concurrency level, affects number of pointclouds queued for processing and number of threads used
            # 0 : Detect number of cores
            # 1 : Single threaded
            # 2->inf : Parallelism level
            concurrency_level: 1
        </rosparam>

    </node>

</launch>

if i change the target_frame with base_link, then i have an error about the transform tolerance being to small(it was at that point 0.1). Even incresing that value does not help.

edit retag flag offensive close merge delete