Ask Your Question
0

Error launching "pepper_bringup pepper_full.launch"

asked 2016-12-09 05:05:49 -0600

Sasamori gravatar image

updated 2016-12-09 06:36:07 -0600

Hello ! Thank you for viewing this question. I have recently tried to launch pepper_bringup pepper_full.launch on Ubuntu 16.04 LTS. I use ROS kinetic. But I couldn't connect to pepper. In this August, I could connect to pepper that command. When I tried it in this November , it was failed !

I was following this site from http://wiki.ros.org/pepper_bringup

Please help me !!

$ roslaunch pepper_bringup pepper_full.launch nao_ip:=192.168.11.24 network_interface:=wlp2s0



SUMMARY
========

PARAMETERS
 * /pepper_robot/pose/pose_manager/poses/init/joint_names: ['Body']
 * /pepper_robot/pose/pose_manager/poses/init/positions: [0.0, 0.0, 1.39, ...
 * /pepper_robot/pose/pose_manager/poses/init/time_from_start: 1.5
 * /pepper_robot/pose/pose_manager/poses/zero/joint_names: ['Body']
 * /pepper_robot/pose/pose_manager/poses/zero/positions: [0.0, 0.0, 0.0, 0...
 * /pepper_robot/pose/pose_manager/poses/zero/time_from_start: 1.5
 * /pepper_robot/pose/pose_manager/xap: /opt/ros/kinetic/...
 * /rosdistro: kinetic
 * /rosversion: 1.12.6

NODES
  /pepper_robot/pose/
    pose_controller (naoqi_pose/pose_controller.py)
    pose_manager (naoqi_pose/pose_manager.py)
  /pepper_robot/
    naoqi_driver (naoqi_driver/naoqi_driver_node)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[pepper_robot/naoqi_driver-1]: started with pid [2735]
process[pepper_robot/pose/pose_controller-2]: started with pid [2736]
process[pepper_robot/pose/pose_manager-3]: started with pid [2737]
Receiving information about robot model
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/naoqi_pose/pose_controller.py", line 49, in <module>
    from naoqi_driver.naoqi_node import NaoqiNode
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/naoqi_driver/__init__.py", line 29, in <module>
    from .naoqi_node import *
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/naoqi_driver/naoqi_node.py", line 37, in <module>
    raise RuntimeError("Error importing NaoQI. Please make sure that Aldebaran's NaoQI API is in your PYTHONPATH.")
RuntimeError: Error importing NaoQI. Please make sure that Aldebaran's NaoQI API is in your PYTHONPATH.
set prefix successfully to 
[I] 1481279744.207391 2735 qimessaging.session: Session listener created on tcp://0.0.0.0:0
[I] 1481279744.208074 2735 qimessaging.transportserver: TransportServer will listen on: tcp://127.0.0.1:38764
[I] 1481279744.208117 2735 qimessaging.transportserver: TransportServer will listen on: tcp://192.168.11.39:38764
using ip address: 127.0.0.1 @ wlp2s0
[pepper_robot/pose/pose_controller-2] process has died [pid 2736, exit code 1, cmd /opt/ros/kinetic/lib/naoqi_pose/pose_controller.py --pip=192.168.11.24 --pport=9559 __name:=pose_controller __log:=/home/cm9/.ros/log/b85df216-bdf9-11e6-a10b-5ce0c51af77f/pepper_robot-pose-pose_controller-2.log].
log file: /home/cm9/.ros/log/b85df216-bdf9-11e6-a10b-5ce0c51af77f/pepper_robot-pose-pose_controller-2*.log
found a catkin prefix /opt/ros/kinetic/share/naoqi_driver/share/boot_config.json
load boot config from /opt/ros/kinetic/share/naoqi_driver/share/boot_config.json
no camera information found for camera_source 3 and res: 1
found a catkin URDF /opt/ros/kinetic/share/naoqi_driver/share/urdf/pepper.urdf
Audio Extractor: Start
RightBumperPressed
LeftBumperPressed
BackBumperPressed
ROS-Driver-RightBumperPressed : Start
HandRightBackTouched
HandRightLeftTouched
HandRightRightTouched
HandLeftBackTouched
HandLeftLeftTouched
HandLeftRightTouched
ROS-Driver-HandRightBackTouched : Start
FrontTactilTouched
MiddleTactilTouched
RearTactilTouched
ROS-Driver-FrontTactilTouched : Start
registered subscriber:  teleop
registered subscriber:  moveto
registered subscriber:  speech
nodehandle reset 
terminate called after throwing an instance of 'ros::InvalidNameException'
  what():  The node name must not be empty
================================================================================REQUIRED process [pepper_robot/naoqi_driver-1] has died!
process has died [pid 2735, exit code ...
(more)
edit retag flag offensive close merge delete

Comments

Please use the Preformatted Text button (the one with 101010 on it) to properly format console copy/pastes, launch files and code. That makes things much easier to read. Just select the text and press the button (or ctrl+k).

Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2016-12-09 05:54:29 -0600 )edit

Thank you for your comments. I changed text format.

Sasamori gravatar imageSasamori ( 2016-12-09 06:43:31 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-12-13 04:49:29 -0600

Sasamori gravatar image

updated 2017-04-07 04:31:28 -0600

I try "roslaunch pepper_bringup pepper_full_py.launch ... " I succeed in connecting to pepper ! But I cannot "roslaunch pepper_bringup pepper_full.launch..." .

I edit "pepper_full.launch" file after.

<launch>

  <arg name="nao_ip"              default="$(optenv NAO_IP)" />
  <arg name="nao_port"            default="$(optenv NAO_PORT 9559)" />

  <arg name="roscore_ip"          default="127.0.0.1" />
  <arg name="network_interface"   default="eth0" />

  <arg name="namespace"           default="pepper_robot" />

  <!-- naoqi driver -->
  <include file="$(find naoqi_driver)/launch/naoqi_driver.launch"  >
    <arg name="nao_ip"            value="$(arg nao_ip)" />
    <arg name="nao_port"          value="$(arg nao_port)" />
    <arg name="roscore_ip"        value="$(arg roscore_ip)" />
    <arg name="network_interface" value="$(arg network_interface)" />
  </include>

  <!-- launch pose manager -->
  <include file="$(find naoqi_pose)/launch/pose_manager.launch" ns="$(arg namespace)/pose" >
    <arg name="nao_ip"            value="$(arg nao_ip)" />
    <arg name="nao_port"          value="$(arg nao_port)" />
  </include>

  <!-- launch perception -->
  <include file="$(find pepper_bringup)/launch/perception.launch.xml">
    <arg name="namespace"         value="$(arg namespace)" />
  </include>

</launch>

I can launch "pepper_full.launch" !

edit flag offensive delete link more
0

answered 2017-07-01 00:45:41 -0600

sinhpo gravatar image

In ROS Kinetic, if you have a node which has no name; i.e in the ros::init() function then you get this error. What I think will work is that, in the source code find the above mentioned function (ros::init(argc, argv, "")) and then add some name to it, for example : ros::init(argc, argv, "some_name");. It would probably be in the file where the main node is declared. This will get rid of the error.

This was acceptable in indigo and lesser versions of ROS but from kinetic they seem to have change that. Thus this error. I hope it helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-12-09 05:05:49 -0600

Seen: 581 times

Last updated: Jul 01 '17