Ask Your Question
0

No response from "turtlebot" pc

asked 2016-12-05 15:00:54 -0500

axel0143 gravatar image

Hi, i have been following this tutorial http://wiki.ros.org/turtlebot/Tutoria...

But after editing my .bashrc according to the tutorial on both pcs like this:

Desktop PC:

export ROS_MASTER_URI=http://192.168.1.150:11311

export ROS_HOSTNAME=192.168.1.107

Laptop PC:

export ROS_MASTER_URI=http://localhost:11311

export ROS_HOSTNAME=192.168.1.150

I am not able to get any sort of communication between the two PCs. For instance, when i run roscore from the laptop (192.168.1.150) and rostopic list from my desktop (192.168.1.107), my desktop PC has no response at all. The same the other way around (even if i change the .bashrc ofc). I am using vmware on both PCs with a bridged connection that "replicates host pc connection", dont know if that has anything to do with it. I can ping the PCs with each other.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-12-06 02:29:08 -0500

MarkyMark2012 gravatar image

updated 2016-12-07 01:04:55 -0500

Sorry I meant to say ROS_IP not ROS_HOSTNAME -

Set ROS_IP=192.168.1.150 on the Desktop PC and on Laptop

Mark

edit flag offensive delete link more

Comments

With:

Desktop PC:

export ROS_MASTER_URI=http://192.168.1.150:11311

export ROS_HOSTNAME=192.168.1.150

Laptop PC:

export ROS_MASTER_URI=http://localhost:11311

export ROS_HOSTNAME=192.168.1.150

Rostopic list from the laptop gives "unable to communicate with master" and desktop gives no response.

axel0143 gravatar image axel0143  ( 2016-12-06 12:54:23 -0500 )edit

Desktop gives no response with those .bashrc settings no matter whether i run rostopic list or roscore. And thank you for responding!

axel0143 gravatar image axel0143  ( 2016-12-06 12:56:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-12-05 14:56:12 -0500

Seen: 90 times

Last updated: Dec 07 '16