Ask Your Question
0

use rtabmap/grid_map for move_base

asked 2016-11-29 03:24:01 -0600

gijsje170 gravatar image

updated 2016-12-13 07:21:03 -0600

I can not get move_base to work with the rtabmap grid_map. I used this link to try and get some direction http://wiki.ros.org/rtabmap_ros/Tutor... and changed the openni_points to my laserscan but whenever i send a command the robot will just start to rotate (recovery behaviour?) in place. I am using an roomba 780 as vehicle with an Kinect mounted on top of it for navigation and 3D mapping. Even when using the Pointcloud2 variable it will instantly go into recovery mode.d

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-11-29 08:26:29 -0600

matlabbe gravatar image

updated 2016-11-29 08:26:47 -0600

I suggest to read the navigation stack tutorial for more ducumentation on move_base's parameters used: http://wiki.ros.org/navigation/Tutori...

openni_points is a PointCloud2 data_type, if you want to use a laser scan, it should be LaserScan data_type. See tutorial above.

Your setup is also similar to Turtlebot, you may look at this tutorial as well: http://wiki.ros.org/rtabmap_ros/Tutor...

cheers

edit flag offensive delete link more

Comments

Hi matlabbe when using the second link i keep getting problems, my move_base_node won't react to goals anymore also my local costmap still shows an empty map for some reason

gijsje170 gravatar imagegijsje170 ( 2016-12-13 06:18:40 -0600 )edit

The local costmap is independent of rtabmap, there should be an error with parameters namespace. What are your launch files and move_base yaml files?

matlabbe gravatar imagematlabbe ( 2016-12-13 09:45:38 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-11-29 03:24:01 -0600

Seen: 717 times

Last updated: Dec 13 '16