"Key server error" on installing kinetic on ubuntu 16.04

asked 2016-11-26 04:51:17 -0600

koolniran gravatar image

updated 2016-11-26 04:56:51 -0600

gvdhoorn gravatar image

Hi

I am trying to install ros kinectic on ubuntu 16.04. I am receiving the error below when trying to install.

sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 0xB01FA116

Error:

Executing: /tmp/tmp.nMOeeZtYBM/gpg.1.sh --keyserver
hkp://ha.pool.sks-keyservers.net:80
--recv-key
0xB01FA116
gpg: requesting key B01FA116 from hkp server ha.pool.sks-keyservers.net
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

Is this an error due to key server not responding or am I missing something in installation? Any help to resolve this problem is appreciated

edit retag flag offensive close merge delete

Comments

See ros-infrastructure/roswiki#140. Have you tried again after waiting a bit?

Note that these servers are managed by 3rd parties, so we can't really control them.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-26 05:02:02 -0600 )edit

I tried multiple times after waiting. So basically I need to wait till the server respond to move ahead am I right? Or is there any way around?

koolniran gravatar imagekoolniran ( 2016-11-26 05:07:09 -0600 )edit

What is the output of ping ha.pool.sks-keyservers.net? Please make sure you have nc or ncat and see whether nc ha.pool.sks-keyservers.net 80 succeeds. I can reach the server(s) from my own machine, so it would seem they are up.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-26 06:33:51 -0600 )edit

Thanks. I think adding "nc" did the trick. I was able to ping but was not able to go ahead with "hkp:" then I changed to nc problems seed to go away. thank again.

We probably need to update this trouble shoot on ros installation page dont we?

koolniran gravatar imagekoolniran ( 2016-11-26 21:48:57 -0600 )edit

I suggested to see whether nc could connect to see whether you could reach ha.pool.sks-keyservers.net:80 at all. nc doesn't do anything with keys. What did you do exactly?

gvdhoorn gravatar imagegvdhoorn ( 2016-11-27 03:51:34 -0600 )edit

I am able to get ping using "nc" but could not get key access using "hkp".

so Instead of " sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 0xB01FA116" I changed to "sudo apt-key adv --keyserver nc ha.pool.sks-keyservers.net:80 --recv-key 0xB01FA116" it worked!.

koolniran gravatar imagekoolniran ( 2016-11-27 17:08:59 -0600 )edit

I don't think inserting nc here actually changed anything, and that "it worked" was merely a coincidence. nc is a stand-alone tool that allows to connect file descriptors to network sockets and use them as stdout & stdin on the cmd line.

Can you try the normal cmd, just to see if it works?

gvdhoorn gravatar imagegvdhoorn ( 2016-11-28 02:06:19 -0600 )edit