Ask Your Question
0

Connect failed RosAria with Robot

asked 2016-11-21 03:49:37 -0600

ThiemPHAM gravatar image

updated 2016-11-21 09:49:13 -0600

gvdhoorn gravatar image

I installed RosAria, and using the command

sudo chmod 777 -R /dev/ttyUSB0

and

rosrun rosaria RosAria

output:

[ INFO] [1479721570.365432614]: RosAria: using port: [/dev/ttyUSB0]
Connnecting to robot using TCP connection to localhost:8101...
Could not connect to simulator, connecting to robot through serial port /dev/ttyUSB0.
Syncing 0 No packet.
Syncing 0 No packet.
Trying close possible old connection
Syncing 0 No packet.
Syncing 0 No packet.
Robot may be connected but not open, trying to dislodge.
Syncing 0 No packet.
Robot may be connected but not open, trying to dislodge.
Syncing 0 No packet.
Could not connect, no robot responding.
Failed to connect to robot.
[ERROR] [1479721576.820760721]: RosAria: ARIA could not connect to robot! (Check ~port parameter is correct, and permissions on port device.)
[FATAL] [1479721576.820794938]: RosAria: ROS node setup failed...

Pleasem help me to fix this problem

edit retag flag offensive close merge delete

Comments

I've cleaned your post up a bit. Should be more readable like this.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-21 09:49:47 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2016-11-29 04:33:39 -0600

ThiemPHAM gravatar image

updated 2016-11-29 04:34:42 -0600

I figured out the error. There is not synchronization between baud rate of RS232 of Robot and that of my computer.

edit flag offensive delete link more
0

answered 2016-11-22 09:50:11 -0600

ReedHedges gravatar image

The messages indicate that ROSARIA (ARIA) is sending "SYNC" commands to the robot and expecting responses, but is not receiving them. Make sure the robot is on and no other software is connected to the robot controller (if this robot also has an internal onboard computer, switch it off). The controller should make a startup initialization sound (see http://robots.mobilerobots.com/wiki/R... ) when it starts up and the STAT light should blink slowly. Press the RESET button to reset if neccesary. Make sure the robot is fully charged or plugged in to the charger (with good batteries). Make sure your USB adapter is an RS-232 adapter ( not TTL serial) and is connected to the SERIAL or HOST port on the side of the robot. When ROSARIA sends each SYNC command, you should see the RX light flash, and you should also see TX light flash as the controller respond. Make sure your USB adapter is /dev/ttyUSB0; check the output of the dmesg command after plugging it in. If you have another, different brand of USB-RS232 adapter you can also try that (we've found most FTDI-based adapters to be reliable, and also many PL2303-based adapters but there are many more manufacturers using that chipset or counterfeits with varying quality). If the controller does not seem to be initializing (no beep or STAT light blinking) you can try connecting with the firmware configuration tool to diagnose.

edit flag offensive delete link more

Comments

thanks your reply,

I tried many times by many methods such as your tutorials, unfortunately it still does not work. i feel really stress

ThiemPHAM gravatar imageThiemPHAM ( 2016-11-25 03:22:14 -0600 )edit

Can you try using the "demo" program included with the ARIA library-- if "demo" from ARIA can't connect then the problem is not ROS related and you can contact support@mobilerobots.com for help (include a reference to this page for our reference).

ReedHedges gravatar imageReedHedges ( 2016-11-28 09:28:23 -0600 )edit

Thanks a lot, i try the "demo" program. Everything is ok

ThiemPHAM gravatar imageThiemPHAM ( 2016-11-28 11:10:02 -0600 )edit
0

answered 2016-11-21 06:55:19 -0600

I have followed tutorial (link) and it works perfectly fine. I have used it on laptop and Raspberry Pi 3 under Linux 16.06 (ROS-Kinetic).

Please let me know if you are following steps mentioned in the tutorial exactly and error after that.

edit flag offensive delete link more

Comments

thanks your reply, i followed these steps in this link , i am using the LANNER and Linux 14.04. Unfortunately, it still dose not work

ThiemPHAM gravatar imageThiemPHAM ( 2016-11-21 08:49:14 -0600 )edit

I do not understand why you are getting error like RosAria: using port: [/dev/ttyUSB0] Connnecting to robot using TCP .. .. Could not connect to simulator.

Are you doing this (e.g. sudo chmod a+rw /dev/ttyUSB0 or sudo chmod a+rw /dev/ttyS0) ??

Dr Abdul Mannan gravatar imageDr Abdul Mannan ( 2016-11-21 09:04:12 -0600 )edit

I tried this command: sudo chmod a+rw /dev/ttyUSB0 or sudo chmod 777 -R /dev/ttyUSB0 etc, but it dose not connect. I have already connected with Robot Pioneer 3 by my laptop , but when i change an other computer, i still did following tutorial and it does not work

ThiemPHAM gravatar imageThiemPHAM ( 2016-11-21 09:16:19 -0600 )edit

"... Could not connect to simulator." is normal. (It should be a separate line from the preceding message. ) Based on the other messages it is opening the port ok but robot is not responding. What kind of robot is it, does it beep, and what port on the robot are you connecting your USB adapter to?

ReedHedges gravatar imageReedHedges ( 2016-11-21 09:37:24 -0600 )edit
1

My robot is pioneer 3, and when i turn on, it has a beep. I use USB adapter to RS232. Please help me to fix this problem.

ThiemPHAM gravatar imageThiemPHAM ( 2016-11-21 09:43:53 -0600 )edit

I believe you have many USB ports. You have to connect it to that USB which is named as USB0. I hope you can figure it out. Remember, you cannot change your USB port in run time.

Dr Abdul Mannan gravatar imageDr Abdul Mannan ( 2016-11-21 20:00:25 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-21 03:49:37 -0600

Seen: 527 times

Last updated: Nov 29 '16