rosserial mbed with EFM32 Wonder Gecko - no sync

asked 2016-11-10 15:45:06 -0600

Piachnp gravatar image

I've been using rosserial with arduinos effectively, but now I need more horsepower so I am trying out the mbed boards. I have an NXP-LPC1768 and a EFM32 Wonder Gecko.

The NXP has worked out of the box without a problem. However I can't get the Gecko to work. It is supposed to be an "mbed enabled" board, so it is supported by rosserial. The program I am flashing is the Hello world example. It is being flashed successfully because I see the LED1 light blinking as the code indicates. However when I run the command

rosrun rosserial_python /dev/ttyACM0 _baud:=115200

the communication is never established. The baudrate should be right since the Gecko itself contains a readme saying the Virtual COM port speed is currently fixed at 115200 bps.

I am using the mbed online compiler for this, where I import the Hello World example from here. It is worth mentioning that I had to update the firmware in the Gecko such that it would show up as a USB Mass Storage device like all mbed devices do. Nothing weird here, I used the official Simplicity Studio software to update the Gecko firmware to a newer one.

Any ideas what I might be doing wrong? These same steps work perfectly on the NXP-LPC1768

Thanks in advance,

edit retag flag offensive close merge delete


Hi! Are you sure the serial port is ttyACM0 for the Gecko? Also, the default speed is 57600 (see line 17 in here) or did you change it on the example code?

Gary Servin gravatar image Gary Servin  ( 2016-12-30 20:42:57 -0600 )edit