Connecting Moveit! to Gazebo simulator

asked 2016-11-07 15:23:33 -0600

mrslvgg gravatar image

updated 2016-11-09 14:19:22 -0600

Dear ros community,

I have a custom robot I'm simulating in Gazebo through ROS. Recently, I started to integrate it in Moveit! to exploit its motion planning capabilities. I have already successfully switched to trajectory controllers and set up everything using Moveit! online support.

The problem I'm facing right now is the following:

Briefly, when I click the plan and execute button (after having placed the robot in the desired pose through the RViZ gui) the simulated robot doesn't move and I get the following warning:

Dropping first 1 trajectory point(s) out of 10, as they occur before the current time. First valid point will be reached in 0.499s.

Is there something I am missing? Any workaround to solve this problem? Thanks in advance for your support!

edit 1:

I don't know if it is relevant but I have found out that my rqt_graph: image description

looks different from the one of this working package (which is also identical to the rqt_graph of the package suggested in the comments):

image description

Is possible that I have a wrong configuration? My simulated robot still doesn't move!

edit retag flag offensive close merge delete

Comments

Not sure which robot package you're using but maybe it's worth checking existing threads like this one.

130s gravatar image 130s  ( 2016-11-07 23:06:19 -0600 )edit

Thanks for the answer. I am using simple_controller_manager package. Anyway my issue looks a bit different from the one you linked.

mrslvgg gravatar image mrslvgg  ( 2016-11-08 03:37:38 -0600 )edit

I've always used ROS control and basing my package off this one for MoveIt! with a simulated robot.

JoshMarino gravatar image JoshMarino  ( 2016-11-08 20:14:35 -0600 )edit

I also based my package on this, I have exactly the same configuration. Anyway my simulated robot still doesn't respond to any trajectory action I am sending from moveit!

mrslvgg gravatar image mrslvgg  ( 2016-11-09 14:26:13 -0600 )edit

The warning you are getting is fine. It has to do with the start time being slightly off (I always get it too).

Gazebo is not moving because MoveIt! is most likely publishing to an incorrect topic, my guess is in controllers.yaml.

JoshMarino gravatar image JoshMarino  ( 2016-11-09 19:57:19 -0600 )edit