Ask Your Question
0

.bashrc doesn't work to source my workspace

asked 2016-11-07 06:51:54 -0600

yueweiliang gravatar image

updated 2016-11-07 07:46:39 -0600

gvdhoorn gravatar image

Hi,I have written to the .bashrc to source my workspace ,but some of them don't be sourced by the .bashrc(some can).I don't know why.I use ubuntu 14.04 and x64 ,ros indigo.here is my .bashrc,where is the errors?

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want ...
(more)
edit retag flag offensive close merge delete

Comments

Could you please format file contents (code, launch files, configuration files, etc) using the Preformatted Text button next time? It's the one with 101010 on it. Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-07 07:47:28 -0600 )edit

ok,I am newer,so I just copy ,I will do as you say next time ~

yueweiliang gravatar imageyueweiliang ( 2016-11-09 03:31:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-11-07 08:17:56 -0600

updated 2016-11-07 08:18:31 -0600

Note that sourcing a setup.bash file overwrites any environment variables that were set through a previous "sourcing" of a setup.bash file. At the bottom of your bashrc, you source 4 workspace setup.bash files, and one from the Indigo install, but the only source command that has any lasting effect is the last one. So the environment you see should only have the /home/robot3/test2 workspace active.

If you need all of these workspaces active at the same time, you should either merge them to make one workspace, or read about workspace chaining. Unless you have a good reason to have all of these workspaces, I'd recommend just merging them.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-07 06:51:54 -0600

Seen: 1,148 times

Last updated: Nov 07 '16