Ask Your Question
1

Google Cartographer - Setup Issues

asked 2016-11-05 06:33:29 -0600

MarkyMark2012 gravatar image

Hi All,

I'm trying to get google's cartographer up and running on my turtle-like robot. Using https://google-cartographer-ros-for-t... as a starting point.

I've updated demo_depth_camera_2d.launch & turtle_depth_camera_2d.lua

I have a problem with the tracking_frame parameter - it was set to gyro_link (which I don't have) so I tried setting it to imu_msg and base_link. Both with out success. I keep getting an error message:

 W1105 11:30:18.000000 16684 tf_bridge.cc:51] "imu_msg" passed to lookupTransform argument source_frame does not exist

regardless if:

 tracking_frame = "base_link"

or

tracking_frame = "imu_msg"

Does anyone have any thoughts? My graph is currently looking like:

image description

Thanks

Mark

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-05 07:24:51 -0600

MarkyMark2012 gravatar image

So adding a static transform between the IMU and the base_link seems to have solved the first issue.

<node pkg="tf" type="static_transform_publisher" name="static_transform_publisher3" args="0 0 0.3 0 0 0 1 base_link imu_msg 100"/>

Now getting:

[FATAL] [1478348520.099726403]: F1105 12:22:00.000000 17582 imu_tracker.cc:66] Check failed: (orientation_ * gravity_vector_).z() > 0. (nan vs. 0)
edit flag offensive delete link more
0

answered 2016-12-01 02:21:16 -0600

damonkohler gravatar image

updated 2016-12-01 02:21:38 -0600

"imu_msg" as a frame name sounds fishy to me. Do you have an IMU on your robot or not? If you don't , you'll need to disable using IMU data in your configuration. Based on the imu_tracker error, I expect your IMU data is somehow incorrect/bogus.

edit flag offensive delete link more

Comments

As you saw in my related question - just a gyro publishing out over the IMU stream

MarkyMark2012 gravatar imageMarkyMark2012 ( 2016-12-01 05:08:48 -0600 )edit

I'm still unclear about how to fix this. So did you fix everything by just adding the static transform?

orlando24 gravatar imageorlando24 ( 2019-01-29 01:17:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-11-05 06:33:29 -0600

Seen: 1,072 times

Last updated: Dec 01 '16