Rosdep update error:The read operation timed out

asked 2016-11-05 04:35:58 -0600

Long gravatar image

updated 2016-11-05 13:02:25 -0600

Hello,

I'm troubled in install ROS on Ubuntu 14.04, when I try rosdep update, this is what it shows:

~$ rosdep update
reading in sources list data from /etc/ros/rosdep/sources.list.d
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml
Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
Add distro "groovy"
ERROR: error loading sources list:
    The read operation timed out

Thanks for your respond. I have tried all day, but it never work, it just keep giving me the same error. And I'm not using proxy. This is what it shows after I put wget:

$ wget http://repositories.ros.org/rosdistro_cache/hydro-cache.yaml.gz
--2016-11-06 01:50:59--  http://repositories.ros.org/rosdistro_cache/hydro-cache.yaml.gz
Resolving repositories.ros.org (repositories.ros.org)... 52.9.49.249
Connecting to repositories.ros.org (repositories.ros.org)|52.9.49.249|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 325081 (317K) [application/x-gzip]
Saving to: ‘hydro-cache.yaml.gz’

100%   [======================================================================================================>] 325,081     13.7KB/s   in 36s    

2016-11-06 01:51:36 (8.76 KB/s) - ‘hydro-cache.yaml.gz’ saved [325081/325081]
edit retag flag offensive close merge delete

Comments

This could be a transient error: have you tried again? Does it ever work?

Are you behind a network proxy? What is the output of

wget http://repositories.ros.org/rosdistro_cache/hydro-cache.yaml.gz

for instance?

gvdhoorn gravatar imagegvdhoorn ( 2016-11-05 06:40:47 -0600 )edit