I have trouble changing the velocity of my robot.

asked 2016-11-04 02:42:18 -0500

NKCT gravatar image

updated 2016-11-04 02:45:02 -0500

Now,I'm studying ROS and using and my ROS robot,kobuki. However,I have trouble changing the velocity of the robot!

I set the max_vel_x value to 0.1 of "kobuki_navigation/param/dwa_local_planner_params.yaml" , and I launch ROS nodes with "kobuki_navigation/launch/kobuki_navigation.launch".Then the Terminal window displays "/move_base/DWAPlannerROS/max_vel_x: 0.1" in the parameters list.

However,when I operate my ROS robot with "2D Nav Goal" of RVIZ, the velocity of my robot is obviously faster than 0.1 m/s! I checked topic by "rostopic echo /cmd_vel",and then it shows "linier: x: 0.55"!! Why I can't change the velocity of my robot and what is the "0.55" of "linier: x: 0.55"?

(I tried setting not only 0.1 but also the other "max_vel_x" value, for example 0.2, 0.3, the result is the same. )

Can you please give me information on that?

”Execution environment”

OS:ubuntu 14.04LTS


I'll show "dwa_local_planner_params.yaml" and "kobuki_navigation.launch" below.

Here is "dwa_local_planner_params.yaml "


    # Robot Configuration Parameters - Kobuki
  max_vel_x: 0.1 
  min_vel_x: 0.0

  max_vel_y: 0.1
  min_vel_y: 0.0

  max_trans_vel: 0.1
  min_trans_vel: 0.1
  trans_stopped_vel: 0.1

  max_rot_vel: 1.0 
  min_rot_vel: 0.4  
  rot_stopped_vel: 0.4

  acc_lim_x: 0.05
  acc_lim_theta: 2.0
  acc_lim_y: 0.0 

# Goal Tolerance Parameters
  yaw_goal_tolerance: 0.3 
  xy_goal_tolerance: 0.03 

# Forward Simulation Parameters
  sim_time: 1.0       
  vx_samples: 6       
  vy_samples: 1       
  vtheta_samples: 20  

# Trajectory Scoring Parameters
  path_distance_bias: 64.0      
  goal_distance_bias: 24.0      
  occdist_scale: 0.5            
  forward_point_distance: 0.325 
  stop_time_buffer: 0.2         
  scaling_speed: 0.25           
  max_scaling_factor: 0.2       

# Oscillation Prevention Parameters
  oscillation_reset_dist: 0.05  

# Debugging
  publish_traj_pc : true
  publish_cost_grid_pc: true
  global_frame_id: odom

meter_scoring: true

Here is "kobuki_navigation.launch".


  <!-- kobuki model -->
  <arg name="urdf_file" default="$(find xacro)/xacro.py '$(find kobuki_description)/urdf/kobuki_standalone.urdf.xacro'" />
  <param name="robot_description" command="$(arg urdf_file)" />

  <node pkg="robot_state_publisher" type="robot_state_publisher" name="robot_state_publisher" output="screen">
    <param name="publish_frequency" type="double" value="5.0" />

  <!-- sensor -->
  <node pkg="urg_node" type="urg_node" name="kobuki_urg_node" output="screen">
    <param name="frame_id" value="base_scan" />

  <!-- tf -->
  <node pkg="kobuki_tf" type="kobuki_tf" name="kobuki_tf" output="screen">

  <!-- Map server-->
  <arg name="map_file" default="/home/nkc/Desktop/Map/Map.yaml"/>
  <node name="map_server" pkg="map_server" type="map_server" args="$(arg map_file)">

  <!-- AMCL -->
  <include file="$(find kobuki_navigation)/launch/amcl.launch.xml"/>

  <!-- move_base -->  
 <arg name="cmd_vel_topic" default="/mobile_base/commands/velocity" />
  <arg name="odom_topic" default="odom" />
  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find kobuki_navigation)/param/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find kobuki_navigation)/param/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find kobuki_navigation)/param/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find kobuki_navigation)/param/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find kobuki_navigation)/param/dwa_local_planner_params.yaml" command="load" />
    <rosparam file="$(find kobuki_navigation)/param/move_base_params.yaml" command="load" />
 <remap from="cmd_vel" to="$(arg cmd_vel_topic)"/>
    <remap from="odom" to="$(arg odom_topic)"/>

edit retag flag offensive close merge delete