Ask Your Question
0

rviz not working well

asked 2016-11-03 09:42:01 -0500

Ayush Sharma gravatar image

updated 2016-11-03 11:13:48 -0500

I have followed the http://wiki.ros.org/rviz/UserGuide to install the Rviz. I have used the following command : sudo apt-get install rviz. I have followed the tutorial from http://wiki.ros.org/rviz/Tutorials/Ma... and the package has been created and built. But opening the Rviz is not showing me the output,It is simply showing me a blank screen with grid-lines,not the expected robot. After following external sources ie: "Mastering ROS For robotic programming" , then also the launch files are responding well, but the output is not coming on Rviz software.

I tried reinstalling but it didn't help.

Also, i get the following warning while performing the rosrun command:

ayushas@ayushas-hp-550:~/catkin_ws$ rosrun using_markers basic_shapes

Output:

[ WARN] [1478182897.733692243]: Please create a subscriber to the marker

Seems like there is an issue with the installation. Kindly help me in this regard.

image description

edit retag flag offensive close merge delete

Comments

Have you loaded the Markers display as instructed by the tutorial? I've bumped your karma so you should be able to post a screenshot of rviz.

ahendrix gravatar image ahendrix  ( 2016-11-03 10:56:12 -0500 )edit

As per the tutorial, i have crated the file "basic_shapes.cpp" and have changed the "CMakeLists.txt". But i am not able to correlate my rviz screen with the following tutorial http://wiki.ros.org/rviz/UserGuide . rviz is not showing such features.Have attached the screenshot.Thank you for the help

Ayush Sharma gravatar image Ayush Sharma  ( 2016-11-03 11:15:09 -0500 )edit

The rviz style has changed a little in the past 5 years, but the buttons still have the same labels and are still in the roughly same location. I can still see the Add button in your screenshot.

ahendrix gravatar image ahendrix  ( 2016-11-03 11:36:43 -0500 )edit

But the output should have been a sphere or cube or else. Kindly let me know why am i getting a blank screen instead of the output??

Ayush Sharma gravatar image Ayush Sharma  ( 2016-11-03 11:51:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-11-03 12:07:17 -0500

ahendrix gravatar image

You need to click the Add button and add MarkerDisplay to display your markers.

edit flag offensive delete link more

Comments

Thank you so much sir. I am very new to these topics and i spent few hours for such a small mistake. With such helping comments like yours, it becomes very easy for newbies like us to learn. Thank you sir. Regards

Ayush Sharma gravatar image Ayush Sharma  ( 2016-11-03 12:22:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-03 09:42:01 -0500

Seen: 711 times

Last updated: Nov 03 '16