Ask Your Question
0

CMake Error to install sr4000 camera (swissranger)

asked 2016-10-29 16:20:42 -0500

Abbas gravatar image

updated 2016-10-29 16:28:27 -0500

Hi,

I try to run swissranger camera (sr4000) on ROS. I follow this tutorial http://visionlab.uncc.edu/dokuwiki/us...

I installed the camera on Ubuntu properly. I tried to run it on ROS, but when I run this command (in the tutorial, in the step 3) "catkin_make", I got this error:

CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "driver_base" with
  any of the following names:

    driver_baseConfig.cmake
    driver_base-config.cmake

  Add the installation prefix of "driver_base" to CMAKE_PREFIX_PATH or set
  "driver_base_DIR" to a directory containing one of the above files.  If
  "driver_base" provides a separate development package or SDK, be sure it
has been installed.
Call Stack (most recent call first):
  open_ptrack/swissranger_camera/CMakeLists.txt:10 (find_package)
        -- Configuring incomplete, errors occurred!
See also "/home/abbas/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/abbas/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

How can I solve this issue?

Thanks,

Abbas

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-29 17:24:31 -0500

ahendrix gravatar image

It looks like you're missing the driver_base package, and maybe a few other dependencies

You can install all of the dependencies for your workspace with:

cd ~/catkin_ws
rosdep install --from-paths src -i -y

And then try to build again

edit flag offensive delete link more

Comments

Hi ahendrix, Thank you for your reply. I installed all of the dependencies in my workspace with the codes that you mentioned. Then, I ran catkin_make, but I got the same error (that I mentioned before). I appreciate you for sharing any idea to solve this issue. Thanks, Abbas

Abbas gravatar image Abbas  ( 2016-10-30 10:02:58 -0500 )edit

rosdep should have installed the ros-kinetic-driver-base package, along with a bunch of other dependencies; did it? If you don't remember what rosdep installed, you can check that the package is installed with dpkg -l ros-kinetic-driver-base

ahendrix gravatar image ahendrix  ( 2016-10-30 15:36:44 -0500 )edit

Hi ahendrix, After running "rosdep install --from-paths src -i -y", I got "#All required rosdeps installed successfully" .After running "dpkg -l ros-kinetic-driver-base" I got "dpkg-query: no packages found matching ros-kinetic-driver-base". I am new in ROS. How can I install the package? Thank you

Abbas gravatar image Abbas  ( 2016-10-30 17:00:31 -0500 )edit

Hi ahendrix, I installed the driver from https://github.com/ros-drivers/driver... (for indigo). Then, catkin_make was ran without an error. Thank you, Abbas

Abbas gravatar image Abbas  ( 2016-10-30 17:29:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-29 16:20:42 -0500

Seen: 243 times

Last updated: Oct 29 '16