Ask Your Question
2

ROS move_base costmap not connected error

asked 2016-10-23 08:59:45 -0600

photon gravatar image

I'm using ROS indigo running on 64bit Ubuntu 14.04 LTS. In the project, the nodes and visualisation (Rviz) seems to be functional when I launch the launch file I written. Here are the sensors used in the the project, which is a modified electric scooter:

  • Hokuyo Lidar
  • Phidgets Encoder

When I start moving the scooter using the joystick, the scooter will move physically, but in Rviz, the object detected by the lidar moves to the scooter, instead of the scooter moving in the map. When I did roswtf, it shows that the robot footprint is disconnected, though the rqt graph shows otherwise. Please advise on the possible ways that I can undertake to debug this issue. roswtf screenshot

Here are the node connections. For the navigation stack, I'm using the Teb local planner instead of the default planner.

enter image description here

A screenshot of the tf tree:

enter image description here

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-09-13 19:41:03 -0600

tfoote gravatar image

This error is not related to tf it's saying that a pub-sub connection related to the footprint topic is not connected. This sometimes happens but likely will not effect your system. A workaround to trigger a reconnect is to create a new subscriber for the topic using rostopic echo ...

edit flag offensive delete link more
0

answered 2016-10-24 14:40:52 -0600

AlexandreB gravatar image

If I understand correctly, it seems like the Rviz global frame is one which is fixed to your robot. Try setting it to the "map" frame.

edit flag offensive delete link more

Comments

I set the frame to map, but the problem is still persisting. Here is a screenshot of rviz: https://i.stack.imgur.com/KYTr7.png

photon gravatar imagephoton ( 2016-10-25 01:02:07 -0600 )edit

Have you solved your problem ? I am having a similar problem (relating to the roswtf message), see Subscribing to global_costmap.

gpldecha gravatar imagegpldecha ( 2016-11-14 07:18:28 -0600 )edit

Have you solved this problem ?? I have the same problem ..plz help me

ramadan gravatar imageramadan ( 2018-04-25 00:55:53 -0600 )edit

Did anyone solve this problem? I have it on my senior project and trying to graduate! :D

karimemara17 gravatar imagekarimemara17 ( 2018-11-21 13:36:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-23 08:53:09 -0600

Seen: 771 times

Last updated: Sep 13 '17