ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Create_autonomy stops reacting

asked 2016-10-20 06:43:02 -0500

gijsje170 gravatar image

I am currently using create_autonomy with my Virtual machine . I have ROS hydro installed with create autonomy. But after running it for severel minutes on my roomba 780 I won't be able to send any more cmd_vel messages. Basically the roomba will just continue to move in the last given direction. Is there a simple solution to this problem or could it be caused by the virtual machine for instance?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-10-21 14:00:52 -0500

jacobperron gravatar image

AFAIK, the robot base will latch the latest command received, regardless of the status of the serial connection. For example, if the cable is disconnected mid-operation or the driver is not shutdown properly the robot will continue to execute the latest velocity command. I would double check that the cable you are using is not loose. It could very well be a virtual machine related issue, but I cannot say for sure.

edit flag offensive delete link more


So good news it works perfectly fine when using raspberry so again it has something to do with virtual machine being unable to use USB ports properly.

gijsje170 gravatar image gijsje170  ( 2016-10-26 09:31:08 -0500 )edit

Question Tools

1 follower


Asked: 2016-10-20 06:43:02 -0500

Seen: 140 times

Last updated: Oct 21 '16