Ask Your Question
1

mapviz: local WMTS for tile_map plugin problems [closed]

asked 2016-09-29 17:57:00 -0500

ganhao89 gravatar image

I am trying to build a local tile map server for the tile_map plugin, so I can navigate and show my husky robot in the map at where no internet is available. I followed the link here to build a tile map server:

https://www.linuxbabe.com/linux-serve...

I was able to see my map in a browser when typing 'http://my-server-ipt' after following the instructions in the link above. I was also able to see the tile of a world map in the browser when typing 'http://localhost/osm_tiles/0/0/0.png'. Everything described in the above link works! The problem is, when I launch the mapviz.launch, select 'tile_map' plugin and choose 'Custom WMTS Source', in the Base URL, type 'http://localhost/osm_tiles/{level}/{x}/{y}.png', nothing shows. I tried change the first part of Base URL into http://localhost , http://127.0.0.1/osm_tiles and so on, none of them works. I am thinking maybe I need to do some additional steps after following the above link? I am new to the map server thing, please help!

Actually, if anyone knows how to build a local WMTS for mapviz and give some instructions will be great!

Thanks,

Hao

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ganhao89
close date 2016-10-05 16:59:59.171758

Comments

I posted an even easier way to setup a local WMTS server for MapViz: https://github.com/danielsnider/MapVi...

danielsnider gravatar image danielsnider  ( 2017-02-13 14:51:24 -0500 )edit

Awesome! It's what I am looking for. I was able to get the the OSM work, but had hard time find satellite tiles. Your solution solved my problem! Thanks!

ganhao89 gravatar image ganhao89  ( 2017-02-13 22:35:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-30 14:59:15 -0500

ganhao89 gravatar image

Update: It's now working. I restarted the computer and also restarted the mapviz several times, and suddenly, it worked. I still don't know what was the problem before. But anyway, it works now. So now, if anyone wants to build a local map sever for the tile_map of mapviz, under Ubuntu 16.04, just follow the instruction in the link: https://www.linuxbabe.com/linux-serve...

After done with that, you can put the Base URL: http://your_server_ip/osm_tiles/{leve... Set the Max Zoom to 18 and save it.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2016-09-29 17:57:00 -0500

Seen: 313 times

Last updated: Sep 30 '16