Ask Your Question
0

Can't ssh by name with more than 3 robots

asked 2016-09-27 03:19:45 -0600

Luis Ruiz gravatar image

updated 2016-09-27 03:20:50 -0600

I am using a main computer to launch the ros nodes in 4 robots. These robots have odroids. I can ssh into the robots by name:

ssh odroid@odroid-machine1.local
ssh odroid@odroid-machine2.local
ssh odroid@odroid-machine3.local
ssh odroid@odroid-machine4.local

I can ssh by name to all the robots except 1 odroid@odroid-machine4.local. To that one I need to ssh by ip address but I need to ssh by name to launch the nodes on it.

The network is done with a router, and something funny is happening. If I do not connect the router to internet I cannot ssh odroid-machine4.local by name, only by ip address. If a connect the router to internet everything is fine. The thing is that for some of my experiments I need to move to a place where I do not have internet access.

I think I might have some configuration problems but I do not know how to debug them.

Today I reinstalled Ubuntu from zero on odroid-machine4.local. Then I reinstalled all the software and configured the network as I always do for all the robots. I was able to ssh odroid-machine4.local by name. Then I connected all the robots to the network and again odroid-machine4.local was not recognized by name. It was until I connected the router to internet that I was able to ssh by name.

I even tried with a different router and I have the same problem.

I think I need to configure something but I don't know what.

edit retag flag offensive close merge delete

Comments

1

I sympathise, but technically, this isn't really a ROS-related question, correct?

gvdhoorn gravatar imagegvdhoorn ( 2016-09-27 04:18:44 -0600 )edit

Well, I use it on robots using ROS, so maybe someone had this issue and can guide me.

Luis Ruiz gravatar imageLuis Ruiz ( 2016-09-27 08:02:51 -0600 )edit

So which device is performing the DNS server role here? The router? Or are you depending on bonjour / avahi-like services? Can all the hosts resolve all other hostnames? Is it just the desktop machine that can't resolve the odroid-machine4 name, or do all hosts have problems?

gvdhoorn gravatar imagegvdhoorn ( 2016-09-27 08:55:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-28 00:36:30 -0600

Luis Ruiz gravatar image

updated 2016-09-28 00:38:30 -0600

I asked here and solved the problem. I had to configure the /etc/hosts files properly.

edit flag offensive delete link more

Comments

A name resolution issue then? Strange that it did work for odroid1 to 3, but not for 4. I would've expected it to never work, or always.

Thanks for reporting back.

gvdhoorn gravatar imagegvdhoorn ( 2016-09-28 00:41:45 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-09-27 03:19:45 -0600

Seen: 59 times

Last updated: Sep 28 '16