Ask Your Question
0

ros libuvc_camera stopped working

asked 2016-09-17 23:36:30 -0600

Hariharan Veerappan gravatar image

updated 2016-09-18 00:13:45 -0600

I am using the rosrun on Nvidia Ubuntu 14.04 platform and i have USB Camera ( UVC Complaint ), i ran the following,

roscore rosrun libuvc_camera camera_node

It worked fine, then i started installing the other components like kinect, stereo camera drivers ( some more components )

after that it stopped working,

root@tegra-ubuntu:/home/ubuntu# rosrun --debug libuvc_camera camera_node

[rosrun] Looking in catkin libexec dirs: /opt/ros/indigo/lib/libuvc_camera

[rosrun] Looking in rospack dir: /opt/ros/indigo/share/libuvc_camera

[rosrun] Searching for camera_node with permissions /111

[rosrun] Running /opt/ros/indigo/lib/libuvc_camera/camera_node

uvc_start_iso_streaming: Busy (-6)

before running this command, i have two video nodes video0 & video1 and i could able to see both videos using luvcview.

After i ran this command, i got only the video0 only ( also it seems that earlier video1 node becomes video0 )

Please share your inputs

edit retag flag offensive close merge delete

Comments

Please use the Preformatted text button to format console copy/pastes. It's the on with 101010 on it.

Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2016-09-18 02:48:05 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-31 22:33:16 -0600

I have met this issue too. And, I found that, if i uninstall "compressed-image-transport", then it works again. But, I still don't know how to resolve it without uninstalling "compressed-image-transport".

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-09-17 23:36:30 -0600

Seen: 240 times

Last updated: Sep 18 '16