Ask Your Question
0

error in Running SLAM on the differential drive robot [closed]

asked 2016-09-12 16:08:06 -0500

zakizadeh gravatar image

i run example of slam in Mastering ROS for Robotics Programming book page 148 . $ roslaunch diff_wheeled_robot_gazebo diff_wheeled_gazebo_full.launch $ roslaunch diff_wheeled_robot_gazebo gmapping.launch

every thing is ok . but when i run : $ roslaunch diff_wheeled_robot_control keyboard_teleop.launch

i have this error : ERROR: cannot launch node of type [diff_wheeled_robot_control/diff_wheeled_robot_key]: can't locate node [diff_wheeled_robot_key] in package [diff_wheeled_robot_control]

the code is here : link text

please help me

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by zakizadeh
close date 2016-09-15 17:47:08.912506

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-12 20:47:58 -0500

DavidN gravatar image

updated 2016-09-12 20:48:07 -0500

When you see "cannot locate node..." error, first thing to do is to check for missing dependency. Most common way is using rosdep. Take a look at this: http://answers.ros.org/question/75241...

edit flag offensive delete link more

Comments

when i run this code : rosdep install --from-paths ~/catkin_ws/src --ignore-src --rosdistro=ROSDISTRO i have this error : ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: diff_wheeled_robot_gazebo: Cannot locate rosdep definition for [gazebo_ro

zakizadeh gravatar imagezakizadeh ( 2016-09-13 11:58:02 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-09-12 16:06:34 -0500

Seen: 132 times

Last updated: Sep 12 '16