Ask Your Question
0

Problem with Jenkins / bloom-release

asked 2016-09-12 04:07:29 -0500

Hello,

I am struggling with a persistent error with one of my packages: in the past we have done several releases (bloom-release) without problems, but since a few weeks ago Jenkins is persistently complaining about:

Invoking 'git clone --branch debian/ros-kinetic-mrpt-ekf-slam-3d_0.1.1-0_jessie --depth 1 --no-single-branch https://github.com/mrpt-ros-pkg-release/mrpt_slam-release.git /tmp/sourcedeb/source'
Cloning into '/tmp/sourcedeb/source'...
fatal: Remote branch debian/ros-kinetic-mrpt-ekf-slam-3d_0.1.1-0_jessie not found in upstream origin

Indeed, that branch does not exist: I can only see these tags:

debian/ros-kinetic-mrpt-ekf-slam-3d_0.1.1-0_xenial
debian/ros-kinetic-mrpt-ekf-slam-3d_0.1.1-0_willy

Here is the complete log: http://build.ros.org/job/Ksrc_dJ__mrp...

My actual questions are:

1) Is there something that I might have done wrong while releasing the package with bloom-release?

2) If not, how can I fix it, apart of doing a "fake" new release as a workaround?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-09-12 12:50:10 -0500

Dirk Thomas gravatar image

When you ran bloom it probably mentioned a problem when creating the release for Debian Jessie. Most likely due to some missing dependencies. You can either look in the ~/.bloom/logs (or similar) folder for the console output or just try to run it again.

If a dependency is not defined for Jessie you can contribute the missing rule to the rosdistro repo and after it had been merged a new release should pass for Jessie.

edit flag offensive delete link more

Comments

Same error on my project here. When I do bloom-release, no errors, "jessie" is just not processed, only debian "willy", "xenial" and rpm "23", "24". bloom version = 0.5.20

matlabbe gravatar image matlabbe  ( 2016-09-27 19:02:26 -0500 )edit

nevermind, I had an old version of bloom-release from http://packages.ubuntu.com/xenial/pyt... ( 0.5.20 ), upgrading to version in http://packages.ros.org/ros/ubuntu ( 0.5.22) solved the problem.

matlabbe gravatar image matlabbe  ( 2016-09-28 08:24:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2016-09-12 04:07:29 -0500

Seen: 89 times

Last updated: Sep 12 '16